Bug 895862 - failed update for fc18
failed update for fc18
Status: CLOSED DUPLICATE of bug 892061
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-16 02:23 EST by Steve
Modified: 2013-01-23 22:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-23 22:07:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of # rpm -qa | grep fc17 (4.52 KB, text/plain)
2013-01-16 02:26 EST, Steve
no flags Details

  None (edit)
Description Steve 2013-01-16 02:23:35 EST
Description of problem:
ran fedup and system unusable due to failures to install

Version-Release number of selected component (if applicable):
fedora 18

How reproducible:
one of one installations

Steps to Reproduce:
1. run fedup against dvd-iso
2. system hung during boot
3. reboot with option single
4. at command prompt run "yum update"
5. system broken at logon screen, remote ssh available
6. run "yum --nopgpcheck update" 
7. 836 packages updated
8. system broken at logon screen, remote ssh available
9. manually check packages and need to do
   yum remove <package>
   yum install <package>
   as yum update <package> does not work
  
Expected results:
system should upgrade from fc17 to fc18 without error

Additional info:
list of files
Comment 1 Steve 2013-01-16 02:26:47 EST
Created attachment 679394 [details]
output of # rpm -qa | grep fc17

list of files not upgraded
Comment 2 Will Woods 2013-01-23 22:07:02 EST
This is due to a broken upgrade path for KDE packages in F18. See bug 888085 for details about that.

The general problem is that fedup doesn't install packages from the media if your system already has newer versions of those packages.

*** This bug has been marked as a duplicate of bug 892061 ***

Note You need to log in before you can comment on or make changes to this bug.