Bug 895943 - katello nightly and headpin nightly are throwing different outputs on same call even though both have same versions of rpms .
katello nightly and headpin nightly are throwing different outputs on same ca...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Tom McKay
Tazim Kolhar
: Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-01-16 05:40 EST by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:03:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Miroslav Suchý 2013-01-16 07:21:20 EST
Both strings are defined in src/app/models/organization.rb  - one on line 53 (this happen for Katello), second on line 73 (this happen for Headpin)

I'm not sure why for Headpin is applied one validator and for Katello second validator.
Easy solution is just to merge both strings, but I'm really courious why we have two similar validator and sometimes is used one and sometimes the other.
Comment 3 Tazim Kolhar 2013-01-16 07:31:36 EST
The summary of the issue faced is as follows :

headpin-nightly and katello-nightly are throwing different output on same call
although both of them have same rpms installed 


1.Katello nightly:

# katello --username "admin" --password *****
org create --name "BAZ1358325326" --description "existing org" --label
"BAR1358325326"
Validation failed: Name has already been taken, Label already exists
(including organizations being deleted)

katello-configure-1.3.3-1.git.5.0f1d8f6.el6.noarch
katello-glue-candlepin-1.3.3-1.git.9.9377ddb.el6.noarch
katello-agent-1.1.3-1.el6.noarch
katello-common-1.3.3-1.git.9.9377ddb.el6.noarch
katello-glue-pulp-1.3.3-1.git.9.9377ddb.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-repos-1.3.2-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-1.3.3-1.el6.noarch
katello-selinux-1.3.1-1.el6.noarch
katello-1.3.3-1.git.9.9377ddb.el6.noarch
katello-glue-foreman-1.3.3-1.git.9.9377ddb.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-1.3.3-1.el6.noarch
katello-certs-tools-1.1.9-1.el6.noarch

2. For Headpin-Nightly :

# headpin --username "admin" --password **** org create --name "BAZ1358325326" --description "existing org" --label "BAR1358325326"
Validation failed: Organization Names and labels must be unique across all organizations

katello-common-1.3.3-1.git.9.9377ddb.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.3.3-1.el6.noarch
katello-certs-tools-1.1.9-1.el6.noarch
katello-glue-candlepin-1.3.3-1.git.9.9377ddb.el6.noarch
katello-cli-1.3.3-1.el6.noarch
katello-headpin-1.3.3-1.git.9.9377ddb.el6.noarch
katello-configure-1.3.3-1.git.5.0f1d8f6.el6.noarch
katello-headpin-all-1.3.3-1.git.9.9377ddb.el6.noarch
katello-selinux-1.3.1-1.el6.noarch
katello-repos-1.3.2-1.el6.noarch


Output format for the same call must be same
Comment 4 Tom McKay 2013-03-27 11:05:28 EDT
@Tazim - Please re-try with latest katello nightly builds. It appears the duplicate strings are no longer present.
Comment 5 Tom McKay 2013-08-28 14:09:42 EDT
@Tazim - Please retest
Comment 6 sthirugn@redhat.com 2013-08-30 15:47:59 EDT
Verified.

In katello nightly:
katello> org create --name "bugtest" --description "bugtest" --label "bugtest"
Successfully created org [ bugtest ]
katello> org create --name "bugtest" --description "bugtest" --label "bugtest"
Validation failed: Name has already been taken, Label already exists (including organizations being deleted), Organization Names and labels must be unique across all organizations


In SAM 1.3 build:
# headpin -u admin -p admin shell
sam> org create --name "bugtest" --description "bugtest" --label "bugtest"
Successfully created org [ bugtest ]
sam> org create --name "bugtest" --description "bugtest" --label "bugtest"
Validation failed: Name has already been taken, Label already exists (including organizations being deleted), Organization Names and labels must be unique across all organizations

* candlepin-0.8.24-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.24-1.el6sam.noarch
* candlepin-tomcat6-0.8.24-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-9.el6sat.noarch
* katello-cli-common-1.4.3-9.el6sat.noarch
* katello-common-1.4.3-11.el6sam_splice.noarch
* katello-configure-1.4.4-3.el6sat.noarch
* katello-glue-candlepin-1.4.3-11.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-11.el6sam_splice.noarch
* katello-headpin-1.4.3-11.el6sam_splice.noarch
* katello-headpin-all-1.4.3-11.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 8 errata-xmlrpc 2013-10-01 07:03:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.