This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 895947 - redeclipse included not clear content
redeclipse included not clear content
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: redeclipse (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Erik Werner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-01-16 05:46 EST by mejiko
Modified: 2013-05-21 23:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: redeclipse-1.4-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 23:14:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mejiko 2013-01-16 05:46:09 EST
Hello.

redeclipse included non-free (not clear) content licenses.

See: /usr/share/doc/redeclipse-data-1.2/all-licenses


non-free license list:


"Akashi-Font" license

not permitted distribute. 


"custom" license

not permitted resell.


"Mark-Policy" license

Restricted modify. I think that this license is trademark" license.


All "content" license is CC-BY-SA, free content license (example: zlib, OFL, etc...), public domain, and dual license. (CC-BY-SA and non-free license)

Question: Which is dual license style ?


A) Dual license is apply "a OR b" style. (Its no problem.) 

Example: Perl


B) Dual license is apply "a AND b" style (Its license problem.)

Example: OpenSSL


Seggests:

1. Remove non-free contents.
2. Replace fedora free contents.
3. Choose CC-BY-SA (If dual license is "A" style)
4. Remove Fedora repos.

Thanks.


Reference:

http://sourceforge.net/apps/mediawiki/redeclipse/index.php?title=Trademark_Policy
http://redeclipse.svn.sourceforge.net/viewvc/redeclipse/doc/all-licenses.txt
https://libregamewiki.org/Libregamewiki:Rejected_games_list#R
https://fedoraproject.org/wiki/Packaging:Guidelines#Code_Vs_Content
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Content_Licenses
https://www.openssl.org/source/license.html
http://dev.perl.org/licenses/
Comment 1 mejiko 2013-01-16 05:46:51 EST
Blocking FE-Legal, This is license problem.
Comment 2 mejiko 2013-01-16 05:51:28 EST
I found typo. (in Description)

incorrent: trademark"

corrent: "trademark"

Sorry.
Comment 3 Martin Erik Werner 2013-01-16 06:50:42 EST
I'm the packager for Red Eclipse in fedora and also the one fiddling with licensing in the Red Eclipse Team.

I've interpreted these licenses as OK, for these reasons:

1. Akashi-Font
   The license clarification given by the author[1] I've interpreted as allowing redistribution, since it implies that we can do everything including making the ttf available to the public (since akashi is "non-paid" on the tenbytwenty homepage).
   Is this an insufficient clarification?

2. custom and CC-BY-3.0-US[2]
   I've interpreted this similar to the OFL-1.1, that when these textures are included in Red Eclipse then they are not "as-is" and hence possible to resell, but looking at this again I do see that it's not obvious and/or the right interpretation.

3. Mark Policy
   This is a trademark "license"/policy and not a copyright license, it is very similar to that of LibreOffice, I don't think this is an issue.

4. "Dual License"
   Could you please clarify what you mean with this, what content and licenses specifically? As far as I know everything that has dual licenses are type B AND compatible (my opinion of akashi-license+CC-BY-SA for example) or set set like that by the author (Torley's Custom and CC-BY-SA-3.0-US for example), in both cases the dual licensing is, in my opinion, not the problem (though one of the license itself *might* be)


I am looking into the Torley textures and the Akashi font currently due to earlier comments from the FSF directory, however it can be noted that despite comments of things being unclear and some arguing (as far as I heard, I was not present) they did decide to include Red Eclipse: http://directory.fsf.org/wiki/Red_Eclipse


[1]
###
License: Akashi-Font
 http://www.tenbytwenty.com/
 .
 License Agreement
 .
 By downloading any product from Ten by Twenty, you agree to the following:
 .
     * All products remain property of Ten by Twenty.
     * Products may be used by the licensee in any personal or commercial
       projects (royalty-free).
     * Products may not be resold or redistributed.
     * Wordpress themes may be edited and developed for individual use, but
       credit links must remain in place and adapted themes may not be
       reditributed.
 .
 Clarification:
 .
 I ("Arand") contacted Ed Merrit (of Ten by Twenty) via email, requesting a
 clarification for the font license and received this response:
 .
 > Hi Arand,
 >
 > Basically, you can use the fonts for whatever you like, the only restriction
   being that:
 > If the font is a "paid" one, rather than a free one, you should not make the
   .ttf file available to the public.
 > Other than that I'm happy for you use the font however you like.
 >
 > Ed
 .
 The "akashi" typeface (available from http://www.tenbytwenty.com/akashi.php) is
 made available for free by the author.
###

[2]
###
Files: data/torley/*
Copyright: 2007-2008, Torley Linden
           2010, Red Eclipse Team
License: custom and CC-BY-3.0-US
 All Torley Textures are 512x512 in (lossless) PNG format and seamlessly tiling.
 Use 'em almost however you want — just don't resell as-is — and let me know if
 you make somethin' kewl with 'em. You can also get them in Second Life @
 http://torley.com/here
###
Comment 4 Martin Erik Werner 2013-03-08 09:38:16 EST
As per an email discussion with Torley Linden, the Torley Textures in Red Eclipse are now used under the CC-BY-SA-3.0 license.

Also added upstream is a clarification of the Akashi-Font license.

See https://sourceforge.net/apps/trac/redeclipse/browser/doc/all-licenses.txt

I think this, if not before, now should cover all issues; would it be worth making a new package release with reworded license information, or is this not needed?
Comment 5 Tom "spot" Callaway 2013-03-26 10:18:53 EDT
Hi Martin, thanks for your clarification notes.

The Akashi font license is still non-free because it does not permit commercial distribution (or non-commercial distribution, for that matter).

Their clarification does not resolve this concern. We'd need them to explicitly permit all kinds of distribution of fonts under that license (commercial and non-commecial, original or derived/modified).

I believe this is the only issue remaining.
Comment 6 Martin Erik Werner 2013-04-03 14:56:48 EDT
I am of the opinion that the clarification is enough, since Akashi is a "Free ('Gratis')" font the implication is that you CAN "make the ttf available to the public" and "use them for whatever you like".

But given the comments here I've contacted Ed for further clarification, and prodded more towards OFL.

I'm holding up on uploading to version 1.4 until this is resolved.

Is there any more action that would need to be taken at the moment?
Comment 7 Tom "spot" Callaway 2013-04-03 15:07:08 EDT
Keep in mind that "use" in English does not equal "use" in Legalese. We need them to be clear about the permission to distribute both unmodified and modified versions without any sort of restriction (commercial or otherwise). Moving to OFL would resolve this.

I don't think anything else is a concern for us at this point, just resolving the issue with getting the Akashi fonts under a Free license (or replacing them with fonts that are).
Comment 8 Martin Erik Werner 2013-05-01 08:14:50 EDT
I've had a reply from Ed noting that the Akashi font is now to be considered licensed under the SIL Open Font License (OFL) 1.1.

I will push out packages for 1.4 with this note (or rather, removing the note about Akashi, since the OFL does not have requirements for use in "documents" which I assume the "word art" pre-rendered images in question should be considered as).
Comment 9 Tom "spot" Callaway 2013-05-01 09:58:13 EDT
Awesome, this should resolve all the concerns here. Please just close this bug out when the 1.4 packages get built/pushed.
Comment 10 Bruno Wolff III 2013-05-01 10:06:03 EDT
For f19, it should currently be built with the test version on enet (1.3.7). You'll need to reup the buildroot override for it. Also redeclipse should get added to the enet update, rather than be pushed independently. If it takes you a while you get to the new builds enet might have made it to stable, but it sounds like you are planning on doing this quickly.
Comment 11 Bruno Wolff III 2013-05-02 00:45:52 EDT
enet 1.3.7 went to stable tonight. By the time tonight's f19 compose is done, there shouldn't be a need to worry about the buildroot override and the redeclipse update can be pushed separately.
Comment 12 Fedora Update System 2013-05-02 16:50:12 EDT
redeclipse-1.4-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/redeclipse-1.4-3.fc19
Comment 13 Fedora Update System 2013-05-03 11:19:13 EDT
Package redeclipse-1.4-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redeclipse-1.4-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7335/redeclipse-1.4-3.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-05-21 23:14:19 EDT
redeclipse-1.4-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.