Bug 89596 - xmodmap incorrectly reads config file
xmodmap incorrectly reads config file
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-24 15:45 EDT by Don Porter
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-24 20:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Porter 2003-04-24 15:45:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
When I remap my keyboard to a unix style mapping by placing the following as a
file called ".Xmodmap" in my home directory.  It maps the backspace key to the
backslash both when shift is pressed and when it is not.  The backspace key
should map to the vertical bar when shift is pressed.  This file worked properly
in RH 7.3 and 8.0, but stopped working when I upgraded to 9. 

------------.Xmodmap--------------
! Switch left Control and caps lock
keycode 37 = Control_L
remove lock = Caps_Lock
remove control = Control_L
keycode 37 = Caps_Lock
keycode 66 = Control_L
add Lock = Caps_Lock
add Control = Control_L
! Switch \ and backspace
keycode 22 = backslash bar
keycode 51 = BackSpace


Version-Release number of selected component (if applicable):
XFree86-4.2.0-8

How reproducible:
Always

Steps to Reproduce:
1.Place the file in your home directory.
2.Restart X
3.Hold down shift and hit the backspace key.
    

Actual Results:  The backspace key is mapped to backslash both when shift is not
pressed and when it is.

Expected Results:  The backspace key should have mapped to backslash when shift
is not pressed and should have mapped to the vertical bar when shift is pressed.

Additional info:

If this bug is not addressed shortly, I will downgrade to 8.0 or abandon redhat
all together.  I simply must be able to remap my keyboard.
Comment 1 Mike A. Harris 2003-04-24 20:29:29 EDT
XFree86 4.3.0 has had many xkb changes, and some of the things users did in
the past to customize xkb do not work the same way as they did in the past.

Such reports have shown in the past to be configuration issues and not
bugs.  This is really a technical support question and not a bug report, and
so bugzilla is not the place to deal with it.  Please use XFree86 mailing
list forums to find an answer to the problem as I can't (and wont) provide
tech support in bugzilla.

This is *NOT* a Red Hat specific problem.  If it is a bug at all, it is a
generic XFree86 bug, and you will experience it in *ANY* distribution which
ships XFree86 4.3.0.  If it is not a bug, which is my assumption after
seeing other people report similar things, then it will require you to
relearn some things and seek technical support on XFree86 mailing lists.

The proper place to find out what the problem is and how to deal with it,
is xfree86@xfree86.org, and if a real bug is found (which I doubt), the
proper place to report it in order to get the absolute fastest possible
fix, is http://bugs.xfree86.org

If that is something which you decide to quit using Red Hat Linux for, I'm
sorry to hear that, but so be it.



Comment 2 Don Porter 2003-04-25 09:51:08 EDT
I apologize if I came off too strong in my bug report and I just wanted to thank
you for the direction in solving this problem.  I wish that the new distribution
of XFree86 would have updated the xmodmap man page to indicate that there had
been a change.

Note You need to log in before you can comment on or make changes to this bug.