Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 895967 - [abrt] fedup-0.7.2-1.fc17: download.py:210:download_packages:TypeError: 'NoneType' object is not iterable
[abrt] fedup-0.7.2-1.fc17: download.py:210:download_packages:TypeError: 'None...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
abrt_hash:5ee7e2bf8dfea3f6779c5309c75...
:
: 880987 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-16 06:54 EST by florianappeddu
Modified: 2013-06-23 01:56 EDT (History)
8 users (show)

See Also:
Fixed In Version: fedup-0.7.3-5.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 23:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (769 bytes, text/plain)
2013-01-16 06:54 EST, florianappeddu
no flags Details
File: core_backtrace (352 bytes, text/plain)
2013-01-16 06:54 EST, florianappeddu
no flags Details
File: environ (2.89 KB, text/plain)
2013-01-16 06:54 EST, florianappeddu
no flags Details
File: smolt_data (3.55 KB, text/plain)
2013-01-16 06:54 EST, florianappeddu
no flags Details
fedup-debug.log (2.55 KB, text/plain)
2013-03-28 07:16 EDT, Elad Alfassa
no flags Details

  None (edit)
Description florianappeddu 2013-01-16 06:54:41 EST
Version-Release number of selected component:
fedup-0.7.2-1.fc17

Additional info:
cmdline:        /usr/bin/python /usr/bin/fedup-cli --network 18 --debuglog fedupdebug.log --instrepo http://dl.fedoraproject.org/pub/alt/qa/fedup/f18-RC4/x86_64/
executable:     /usr/bin/fedup-cli
kernel:         3.7.2-201.fc18.x86_64
uid:            0

Truncated backtrace:
download.py:210:download_packages:TypeError: 'NoneType' object is not iterable

Traceback (most recent call last):
  File "/usr/bin/fedup-cli", line 330, in <module>
    main(args)
  File "/usr/bin/fedup-cli", line 275, in main
    pkgs = download_packages(f)
  File "/usr/bin/fedup-cli", line 61, in download_packages
    f.download_packages(updates, callback=output.DownloadCallback())
  File "/usr/lib/python2.7/site-packages/fedup/download.py", line 210, in download_packages
    if set(updates) != set(pkgs):
TypeError: 'NoneType' object is not iterable

Local variables in innermost frame:
localpkgs: []
self: <fedup.download.FedupDownloader object at 0x2651390>
callback: <fedup.textoutput.DownloadCallback instance at 0x28de878>
pkgs: []
total: 0
updates: None
Comment 1 florianappeddu 2013-01-16 06:54:45 EST
Created attachment 679474 [details]
File: backtrace
Comment 2 florianappeddu 2013-01-16 06:54:48 EST
Created attachment 679475 [details]
File: core_backtrace
Comment 3 florianappeddu 2013-01-16 06:54:51 EST
Created attachment 679476 [details]
File: environ
Comment 4 florianappeddu 2013-01-16 06:54:54 EST
Created attachment 679477 [details]
File: smolt_data
Comment 5 Christian Kujau 2013-01-22 23:01:19 EST
> kernel:         3.7.2-201.fc18.x86_64

-> Isn't this a duplicate of bug 880987 ?
Comment 6 Will Woods 2013-01-23 11:26:55 EST
Seems that way - 3.7.2-201.fc18.x86_64 is the F18 kernel, after all.

Can one of the reporters please:

1) check /etc/fedora-release - does it say "Fedora release 18 (Spherical Cow)"?
2) try `yum upgrade` - does it say "Nothing to upgrade" (or similar)?

Obviously I still need a better error message here, so this is still a real bug, but I'd like to be sure this is what's going on.
Comment 7 Will Woods 2013-01-23 13:18:42 EST
Can you also attach your fedupdebug.log?
Comment 8 Will Woods 2013-01-23 13:32:58 EST
*** Bug 880987 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2013-01-31 09:46:07 EST
fedup-0.7.3-0.git20130128.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.3-0.git20130128.fc17
Comment 10 gatlibs 2013-03-12 23:09:02 EDT
I was attempting to upgrade 18 to 19.

Package: fedup-0.7.1-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 11 Fedora Update System 2013-03-15 19:34:19 EDT
fedup-0.7.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.3-1.fc17
Comment 12 gatlibs 2013-03-15 21:00:45 EDT
Should I file another report for 18 to 19?
Comment 13 Fedora Update System 2013-03-16 20:54:12 EDT
Package fedup-0.7.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.7.3-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3956/fedup-0.7.3-1.fc17
then log in and leave karma (feedback).
Comment 14 Elad Alfassa 2013-03-28 07:16:23 EDT
Created attachment 717600 [details]
fedup-debug.log

I just had this crash when trying to upgrade Fedora 18 to Fedora 19. Attached is the relevant debug log
Comment 15 Will Woods 2013-03-28 14:15:37 EDT
...with what version of fedup? It should be fixed in 0.7.3, which is currently in updates-testing.
Comment 16 gatlibs 2013-03-29 22:59:50 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=402988 seemed to fix the error on F18.
Comment 17 Fedora Update System 2013-04-30 10:51:01 EDT
fedup-0.7.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.7.3-3.fc18
Comment 18 Fedora Update System 2013-04-30 10:54:58 EDT
fedup-0.7.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.3-3.fc17
Comment 19 Fedora Update System 2013-04-30 11:37:10 EDT
fedup-0.7.3-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.3-4.fc17
Comment 20 Fedora Update System 2013-04-30 11:38:00 EDT
fedup-0.7.3-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.7.3-4.fc18
Comment 21 Fedora Update System 2013-04-30 11:39:05 EDT
fedup-0.7.3-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.7.3-4.fc19
Comment 22 Fedora Update System 2013-05-14 23:29:37 EDT
fedup-0.7.3-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2013-06-07 12:42:52 EDT
fedup-0.7.3-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.3-5.fc17
Comment 24 Fedora Update System 2013-06-07 23:34:19 EDT
fedup-0.7.3-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2013-06-23 01:56:08 EDT
fedup-0.7.3-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.