Bug 895979 - Menu android sdk manager not visible by default
Menu android sdk manager not visible by default
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-16 07:14 EST by Carlos Soriano
Modified: 2013-02-28 10:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 10:56:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Soriano 2013-01-16 07:14:48 EST
Description of problem:
The menu android sdk manager and android virtual device manager is not visible by default in windows -> android sdk manager.

Version-Release number of selected component (if applicable):
eclipse 4.2.1

How reproducible:
always

Steps to Reproduce:
Fresh installation of fedora 18 and fedora eclipse
1.Search at eclipse marketplace android SDK tools by google.
2.Install the default nstallation. Next, next next...
3.Menu window -> ? not android sdk manager at the bottom
  
Actual results:
Menu window -> sdk manager not visible

Expected results:
Menu window -> sdk manager visible
This is necesary to follow correctly the android tutorial at Google.

Additional info:
Workaround: window -> customize perspective -> command groups availability -> check Android SDK and ADV Manager
Comment 1 Alexander Kurtakov 2013-02-28 08:02:11 EST
Does the same problem happens with eclipse downloaded from eclipse.org?
Comment 2 Krzysztof Daniel 2013-02-28 08:59:14 EST
If you need to enable Android SDK and ADV Manager in the window->customize perspective, it means that it is not enabled on purpose.  

Have you changed the perspecive to one related to Android?
Comment 3 Carlos Soriano 2013-02-28 10:38:53 EST
I also notice this happens with the official google bundle on mac and linux.

Alexander: I didn't test it but as I said it also happens with the official eclipse bundle SDK (I guess it's 4.2 eclipse)

Ktzysztof: In the main instructions on android they ask about start this menu, and a people get lost at this point, because there's not menu (until you go to window->customize perspective).

Since this happens also on MAC users, is the bug not related to eclipse and the package shipped for fedora?
Comment 4 Alexander Kurtakov 2013-02-28 10:56:34 EST
Yes, it's not Eclipse and not Fedora bug. 
The bug is either in Android tools or in their documentation, please contact them to resolve it.
Closing the bug as there is nothing we can do about it.

Note You need to log in before you can comment on or make changes to this bug.