Bug 8960 - ld-linux.so.2 takes all CPU, Netscape hangs on opening a page
Summary: ld-linux.so.2 takes all CPU, Netscape hangs on opening a page
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape-sparc   
(Show other bugs)
Version: 6.1
Hardware: sparc Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-29 13:06 UTC by giova
Modified: 2014-03-17 02:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-07 20:58:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giova 2000-01-29 13:06:21 UTC
Under RH 6.1 Sparc on an Ultra5 270Mhz + QLogic Antares SCSI, the
ld-linux.so.2 library takes 99.9% of the cpu and netscape hangs when
I try to open some urls with the "Open Link In new Window" (central mouse
button) option.
An URL which always reproduces the error is
http://www.repubblica.it/ (today's version) whwn I access multiple articles
(those on the America's Cup, for example)

I can give you an account on the machine, if it's needed.

The library always uses a great amount of cpu time, even when
netscape doesn't hang. (18% to 60% typical, in single web page browsing)

	Hope this helps,

	Giovanni Faglioni, Sys&Net Admin, Comune di Modena.

Comment 1 Bill Nottingham 2000-01-31 05:16:59 UTC
This is because netscape is being run against the glibc-2.0 compatibility
libraries. If you remove the compat-libs and compat-glibc packages,
does the problem persist?

Comment 2 Bill Nottingham 2000-02-02 03:06:59 UTC
Also, one way to alleviate some of the race conditions in netscape
(that's what's causing the hangs), is to run netscape through a
proxy server, such as squid.


Note You need to log in before you can comment on or make changes to this bug.