This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 896015 - Duplicate System Profile deletion (/rhn/systems/DuplicateIPList.do) systems do not appear on the confirmation page (/rhn/systems/ssm/DeleteConfirm.do) if they are currently unentitled.
Duplicate System Profile deletion (/rhn/systems/DuplicateIPList.do) systems d...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
550
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Pavel Studeník
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-01-16 08:34 EST by Ash Westbrook
Modified: 2013-10-01 17:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:50:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/rhn/systems/DuplicateIPList.do (86.12 KB, image/jpeg)
2013-01-16 08:39 EST, Ash Westbrook
no flags Details
/rhn/systems/ssm/DeleteConfirm.do (94.25 KB, image/png)
2013-01-16 08:41 EST, Ash Westbrook
no flags Details

  None (edit)
Description Ash Westbrook 2013-01-16 08:34:19 EST
Description of problem:

Duplicate System Profile deletion (/rhn/systems/DuplicateIPList.do) systems do not appear on the confirmation page (/rhn/systems/ssm/DeleteConfirm.do) if they are currently unentitled.

Version-Release number of selected component (if applicable):

RHN Satellite 550

How reproducible:

Always

Steps to Reproduce:
1. Login as Admin user
2. Go to system profile and remove base and channel entitlements
3. Then go to /rhn/systems/DuplicateIPList.do
4. Select this same system for deletion
5. On the following confirmation page /rhn/systems/ssm/DeleteConfirm.do this system will not appear.
  
Actual results:

Unentitled systems do not appear on /rhn/systems/ssm/DeleteConfirm.do for deletion.

Expected results:

All systems that appear on /rhn/systems/DuplicateIPList.do, whether entitled or not should be available for actual deletion on /rhn/systems/ssm/DeleteConfirm.do

Additional info:

Attached screenshots from customer.
Comment 1 Ash Westbrook 2013-01-16 08:39:40 EST
Created attachment 679593 [details]
/rhn/systems/DuplicateIPList.do
Comment 2 Ash Westbrook 2013-01-16 08:41:00 EST
Created attachment 679594 [details]
/rhn/systems/ssm/DeleteConfirm.do
Comment 3 Tomas Lestach 2013-01-22 06:01:32 EST
dissociate duplicate system set from SSM ...

spacewalk.git: 4714883c49d1fa9e18b925141c50b25c74844ae9
Comment 4 Tomas Lestach 2013-01-31 08:56:29 EST
extra fix ...

spacewalk.git: a61bfd8d340ed57f7020d638eaa03bb310c79c5b
Comment 8 Clifford Perry 2013-10-01 17:50:39 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.