Bug 896024 - parted.version() throws SystemError
Summary: parted.version() throws SystemError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pyparted
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On: 700383
Blocks: 960065
TreeView+ depends on / blocked
 
Reported: 2013-01-16 13:46 UTC by Antoni Segura Puimedon
Modified: 2014-12-08 00:50 UTC (History)
6 users (show)

Fixed In Version: pyparted-3.4-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 700383
Environment:
Last Closed: 2013-11-21 11:21:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1616 normal SHIPPED_LIVE pyparted bug fix update 2013-11-20 21:38:46 UTC

Description Antoni Segura Puimedon 2013-01-16 13:46:16 UTC
The bug can be reproduced on RHEL-6.4, pyparted version
3.4.3-el6
+++ This bug was initially created as a clone of Bug #700383 +++

Description of problem:

[stijn@pclin250] <~> python
Python 2.7 (r27:82500, Sep 16 2010, 18:02:00) 
[GCC 4.5.1 20100907 (Red Hat 4.5.1-3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import parted
>>> parted.version()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "<string>", line 2, in version
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "/usr/lib64/python2.7/site-packages/parted/__init__.py", line 306, in version
    ver['pyparted'] = pyparted_version()
SystemError: error return without exception set

Version-Release number of selected component (if applicable):

[stijn@pclin250] <~> rpm -qa \*parted\*
parted-devel-2.3-4.fc14.x86_64
parted-2.3-4.fc14.x86_64
pyparted-3.4-3.fc14.x86_64

How reproducible:

Always

Expected results:

This is with an up-to-date git of pyparted; installed in a separate location:

[stijn@pclin250] </scratch/stijn/usr/lib64/python2.7/site-packages> python
Python 2.7 (r27:82500, Sep 16 2010, 18:02:00) 
[GCC 4.5.1 20100907 (Red Hat 4.5.1-3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import parted
>>> parted.version()
{'libparted': '2.3', 'pyparted': (3, 6)}

--- Additional comment from Fedora Update System on 2011-08-05 13:36:56 EDT ---

pyparted-3.4-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pyparted-3.4-5.fc14

--- Additional comment from Fedora Update System on 2011-08-05 19:55:22 EDT ---

Package pyparted-3.4-5.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyparted-3.4-5.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/pyparted-3.4-5.fc14
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2011-08-11 19:28:46 EDT ---

pyparted-3.4-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 2 David Cantrell 2013-01-16 15:05:45 UTC
Fixed in Fedora 14, we can backport the patch.

Comment 3 RHEL Product and Program Management 2013-05-06 21:13:50 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 7 Ľuboš Kardoš 2013-09-11 09:13:28 UTC
Verified on pyparted-3.4-4.el6.x86_64.

Comment 8 errata-xmlrpc 2013-11-21 11:21:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1616.html


Note You need to log in before you can comment on or make changes to this bug.