Bug 896073 - thinkpad t520: suspend by closing lid works, opening lid un-suspends and then suspends again.
thinkpad t520: suspend by closing lid works, opening lid un-suspends and then...
Status: CLOSED DUPLICATE of bug 859227
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-16 10:00 EST by jnelson+fedora
Modified: 2013-01-30 07:51 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 07:51:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages during a double suspend/resume cycle (36.46 KB, text/plain)
2013-01-28 08:20 EST, Tommi Kyntola
no flags Details
/var/log/messages during a suspend/resume cycle FAILED CASE (24.24 KB, application/octet-stream)
2013-01-29 11:38 EST, Tommi Kyntola
no flags Details
/var/log/messages during a suspend/resume cycle OK CASE (17.61 KB, application/octet-stream)
2013-01-29 11:40 EST, Tommi Kyntola
no flags Details
/var/log/messages during a suspend/resume cycle OK CASE when in tty2 (16.22 KB, application/octet-stream)
2013-01-29 11:41 EST, Tommi Kyntola
no flags Details
/var/log/messages during a suspend/resume cycle OK CASE suspended from kde menu (16.55 KB, application/octet-stream)
2013-01-29 11:42 EST, Tommi Kyntola
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 809248 None None None Never

  None (edit)
Description jnelson+fedora 2013-01-16 10:00:14 EST
Description of problem:

Suspending the laptop by closing the lid works just fine.
Un-suspending by opening the lid (usually, not 100%) un-suspends, and then immediately suspends again.

Symptoms are the same as this older bug from Fedora 16:
https://bugzilla.redhat.com/show_bug.cgi?id=809248

Version-Release number of selected component (if applicable):

Fedora 18
kernel: 3.7.2-201.fc18.x86_64
Thinkpad T520 with BIOS version 8AET60WW (1.40 ) (fairly recent as of this writing)

I was using Fedora 17 previously, and did not experience the double-suspend.
Comment 1 Tommi Kyntola 2013-01-28 08:20:00 EST
Created attachment 688964 [details]
/var/log/messages during a double suspend/resume cycle

Fedora 18 running vanilla 3.7.5 on Lenovo Thinkpad X1 Carbon. Same thing happens with fedora kernels.

This is /var/log/messages between such a cycle. I closed the lid, it suspended, I opened up the lid, it woke up a bit (saw console again, no X) and then immediately suspended again, I then pressed the power button to wake it up again, it woke up and everything works fine.
Comment 2 Tommi Kyntola 2013-01-29 11:38:33 EST
Created attachment 689939 [details]
/var/log/messages during a suspend/resume cycle FAILED CASE

When in X I closed the lid and reopened only to witness the system suspend again. Lid closed and reopened and then it gets back up.
Comment 3 Tommi Kyntola 2013-01-29 11:40:05 EST
Created attachment 689940 [details]
/var/log/messages during a suspend/resume cycle OK CASE

And about one in five or so it works as expected.
Comment 4 Tommi Kyntola 2013-01-29 11:41:28 EST
Created attachment 689941 [details]
/var/log/messages during a suspend/resume cycle OK CASE when in tty2

And when in some other tty it works every time.
Comment 5 Tommi Kyntola 2013-01-29 11:42:50 EST
Created attachment 689942 [details]
/var/log/messages during a suspend/resume cycle OK CASE suspended from kde menu

And if I do the same thing from the KDE menu it also works every time.
Comment 6 Tommi Kyntola 2013-01-29 13:55:46 EST
Bug 859227 deals with this. Upgrading kde-workspace to a newer version (currently in testing) seems to fix this (with some minor side effects).
Comment 7 Lukáš Tinkl 2013-01-30 07:51:18 EST

*** This bug has been marked as a duplicate of bug 859227 ***

Note You need to log in before you can comment on or make changes to this bug.