Bug 896085 - Multiple networks creation fails in case not specifying the networks sizes
Multiple networks creation fails in case not specifying the networks sizes
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
low Severity low
: async
: 2.1
Assigned To: David Ripton
Rami Vaknin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-16 10:08 EST by Rami Vaknin
Modified: 2016-04-26 18:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-17 17:32:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2013-01-16 10:08:07 EST
Version:
Folsom on RHEL6.4
FlatDHCP
openstack-nova-scheduler-2012.2.2-5.el6ost.noarch
openstack-nova-compute-2012.2.2-5.el6ost.noarch
python-nova-2012.2.2-5.el6ost.noarch
openstack-nova-network-2012.2.2-5.el6ost.noarch
openstack-nova-objectstore-2012.2.2-5.el6ost.noarch
openstack-nova-volume-2012.2.2-5.el6ost.noarch
openstack-nova-2012.2.2-5.el6ost.noarch
python-novaclient-2.10.0-1.el6ost.noarch
openstack-nova-common-2012.2.2-5.el6ost.noarch
openstack-nova-cert-2012.2.2-5.el6ost.noarch
openstack-nova-console-2012.2.2-5.el6ost.noarch
openstack-nova-novncproxy-0.4-2.el6.noarch
openstack-nova-api-2012.2.2-5.el6ost.noarch

Scenario:
Network creation fails with "count outside of current IP subnet boundary!" error when trying to create multiple networks (using the "--num_networks" paramter with value > 1) without specifying the networks sizes (with the "--network_size" parameter).

Results:
Command failed, please check log for more info
2013-01-15 16:21:19 CRITICAL nova [req-dadb472b-1cae-4e03-b309-1630338f51eb None None] count outside of current IP subnet boundary!

Expected Results:
The network_size should be derived from range_size/num_networks - it should succeed only if the result of that devision >=4

Command for example:
nova-manage network create --label=net1 --fixed_range_v4=192.168.1.128/25 --bridge=br100 --project_id=a2d3296b79d74bc5ac647976834b7126 --num_networks=2
Comment 2 David Ripton 2013-02-18 20:41:32 EST
Looks like this was fixed upstream for Folsom.  See https://bugs.launchpad.net/nova/+bug/1046605
Comment 3 David Ripton 2013-03-04 11:44:30 EST
The fix was in commit 7483115f, done on 2012-09-07 and merged to stable/folsom on 2012-09-11.
Comment 4 David Ripton 2013-04-10 14:37:34 EDT
Commit 7483115f has already been merged to rh-folsom-rhel-6-patches
Comment 5 Lon Hohberger 2013-04-17 17:32:34 EDT
This appears to have been resolved some time ago, perhaps in the 2012.2.3 rebase?

I did not check 2012.2.2 (since this bug was reported against it).  The commit referenced in comment 3 is definitely in the GA release of openstack-nova.

Note You need to log in before you can comment on or make changes to this bug.