This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 896096 - [RFE] Specifying the keyname when removing custom info from a system should be required
[RFE] Specifying the keyname when removing custom info from a system should b...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Price
sthirugn@redhat.com
: FutureFeature
Depends On: 895735
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-16 10:48 EST by Adam Price
Modified: 2013-10-01 07:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
CLI now requires the keyname to be specified when remove system custom info.
Story Points: ---
Clone Of: 895735
Environment:
Last Closed: 2013-10-01 07:03:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Scott Lewis 2013-02-25 10:50:34 EST
Moving to appropriate release bucket
Comment 3 sthirugn@redhat.com 2013-09-20 16:54:41 EDT
Verified.

sam> system custom_info add --org ACME_Corporation --name=system1 --keyname key1 --value value1
Successfully added Custom Information [ key1 : value1 ] to System [ system1 ]

sam> system custom_info remove --org ACME_Corporation --name=system1
Usage:   options system custom_info remove options

headpin: error: Option --keyname is required; please see --help

sam> system custom_info remove --org ACME_Corporation --name=system1 --keyname key1
Successfully removed Custom Information from System [ system1 ]

Version Tested:
* candlepin-0.8.26-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-19.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.26-1.el6sam.noarch
* candlepin-tomcat6-0.8.26-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-11.el6sat.noarch
* katello-cli-common-1.4.3-11.el6sat.noarch
* katello-common-1.4.3-15.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-15.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-15.el6sam_splice.noarch
* katello-headpin-1.4.3-15.el6sam_splice.noarch
* katello-headpin-all-1.4.3-15.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 5 errata-xmlrpc 2013-10-01 07:03:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.