Bug 8961 - Circular dependency when installing rpm-3.0.4-0.33.i386.rpm
Circular dependency when installing rpm-3.0.4-0.33.i386.rpm
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-29 09:35 EST by Steven Lee
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-29 10:59:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Lee 2000-01-29 09:35:26 EST
I tried to install rpm-3.0.4-0.33.i386.rpm on Linux 2.2.5-15 and I get an
error saying it needs /bin/bash2.  /bin/bash2 is supposedly generated by
rpm2html 1.3.  I tried to install rpm2html-1.3-1.i386.rpm and it says it
requires librpm.so.0 which is in rpm-3.0.4-0.33.i386.rpm.

-Steven
Comment 1 Jeff Johnson 2000-01-29 10:59:59 EST
Install bash2 from its own package. Rpm requires bash2 (and not bash of /bin/sh)
because there is a patch in the Red Hat bash2 to parse a shell script and
identify which executables will be executed by that script. Rpm will use
this to generate dependencies for %pre/%post scriptlets.

Note You need to log in before you can comment on or make changes to this bug.