Bug 896262 - Update trac-spamfilter-plugin import of PIL for F19 switch to Pillow
Update trac-spamfilter-plugin import of PIL for F19 switch to Pillow
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: trac-spamfilter-plugin (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PILLOW
  Show dependency treegraph
 
Reported: 2013-01-16 17:31 EST by Stephen Gallagher
Modified: 2013-03-08 08:09 EST (History)
2 users (show)

See Also:
Fixed In Version: trac-spamfilter-plugin-0.7.3-0.15.20130228svn11702.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-08 08:09:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Change imports of PIL Library so they'll work with pillow (648 bytes, patch)
2013-01-16 17:31 EST, Stephen Gallagher
no flags Details | Diff

  None (edit)
Description Stephen Gallagher 2013-01-16 17:31:42 EST
Created attachment 679886 [details]
Change imports of PIL Library so they'll work with pillow

Description of problem:

Fedora 19 is switching from using python-imaging (PIL) to python-pillow.  This is mostly backwards compatible but importing the python-imaging relevant libraries is undergoing a change.  In PIL, the libraries could either be imported like this:

import Image

or like this:

from PIL import Image

In python-pillow (and thus, Fedora19+), only the latter will work.  I've grepped the sources and found a few import statements that need to be updated.  Patch attached to fix those.  Patch should be upstreamable as PIL supports both the old and new forms of the import.

Version-Release number of selected component (if applicable):
trac-spamfilter-plugin-0.4.7-0.13.20110716svn10756.fc18
Comment 1 Paul Howarth 2013-01-29 08:48:24 EST
Raised upstream: http://trac.edgewall.org/ticket/11031

I'll update Rawhide in a few days unless upstream has some objections.
Comment 2 Toshio Ernie Kuratomi 2013-02-04 20:54:42 EST
Thanks!  I'll try to remember to ping this bug when the python-pillow package finishes review.  Since it Provides and Obsoletes python-imaging, packages which use the old style of import will stop working when that enters the repository.
Comment 3 Toshio Ernie Kuratomi 2013-03-06 11:16:03 EST
The python-pillow package has passed review.  It will enter rawhide in a short time.  Note that this package will then fail to import PIL unless a version with the updated imports is built.

https://bugzilla.redhat.com/show_bug.cgi?id=908114
Comment 4 Paul Howarth 2013-03-08 08:09:32 EST
No response from upstream so I've done a patched build anyway, updating to a new branch for trac 1.0 support.

Note You need to log in before you can comment on or make changes to this bug.