Bug 89629 - man madvise fails to display man page
man madvise fails to display man page
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: man-pages (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-25 07:39 EDT by greg hosler
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 13:56:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description greg hosler 2003-04-25 07:39:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
man madvise

gives teh following (instead of the man page):

iconv: illegal input sequence at position 177


Version-Release number of selected component (if applicable):
man-pages-1.53-3

How reproducible:
Always

Steps to Reproduce:
1. man madvise
2.
3.
    

Actual Results:  no man page

Expected Results:  the madvise man page

Additional info:
Comment 1 Eido Inoue 2003-07-11 14:19:44 EDT

*** This bug has been marked as a duplicate of 98969 ***
Comment 2 Daniel Roesen 2004-06-27 09:55:37 EDT
Reopening. This is NOT yet fixed in FC1... and I guess not in FC2,
because this bug was marked as duplicate of #98969, but was not fixed
as part of this bug.

$ man madvise | cat
iconv: illegal input sequence at position 175
$ rpm -qf /usr/share/man/man2/madvise.2.gz
man-pages-1.60-4
Comment 3 Eido Inoue 2004-06-28 10:14:13 EDT
you need to upgrade your man package, not just man-pages. Latest for
FC1 is 1.5k-12.

However, it's unclear as to why madvise isn't getting natively
converted (the new man will not give an iccnv error, but will instead
print a warning and work around the incorrectly encoded man page)
Comment 4 Daniel Roesen 2004-08-03 17:22:48 EDT
$ rpm -q man
man-1.5k-12
Comment 5 Eido Inoue 2004-08-20 13:56:41 EDT
confirmed that its not a problem with current release combo (man +
man-pages)

Note You need to log in before you can comment on or make changes to this bug.