Bug 896295 - Port textile's use of PIL to support Pillow for F19
Port textile's use of PIL to support Pillow for F19
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-textile (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PILLOW
  Show dependency treegraph
 
Reported: 2013-01-16 19:27 EST by Toshio Ernie Kuratomi
Modified: 2013-01-30 13:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 13:41:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to use the form of import of PIL that is pillow compatible (1.03 KB, patch)
2013-01-16 19:27 EST, Toshio Ernie Kuratomi
no flags Details | Diff

  None (edit)
Description Toshio Ernie Kuratomi 2013-01-16 19:27:23 EST
Created attachment 679941 [details]
Patch to use the form of import of PIL that is pillow compatible

Description of problem:

Fedora 19 is going to stop shipping python-imaging (PIL) and start shipping python-pillow instead.  Rationale can be found on the feature page: https://fedoraproject.org/wiki/Features/Pillow .  pillow should be compatible with PIL at the code level but the import statement changes slightly.

PIL supports both of these:

import Image

from PIL import Image

Pillow only supports the latter form.

I grepped through the textile source and found some occurrences of "import Image".  I'll attach a patch that updates these to the new form of import.
Comment 1 Toshio Ernie Kuratomi 2013-01-16 19:50:37 EST
Also, python-textile should probably have:

Require: python-imaging

in its spec file
Comment 2 Toshio Ernie Kuratomi 2013-01-29 12:18:59 EST
If I don't hear anything back from you, I'll go ahead and use provenpackager powers to apply this patch to the RawHide package next week.  I'll leave sending the patch to upstream and the decision whether to add python-imaging to the spec file up to you, though.
Comment 3 Thomas Moschny 2013-01-30 13:41:59 EST
Filed a bug upstream: https://github.com/sebix/python-textile/pull/10

To me python-imaging seems to be an optional runtime dependency, so I think we should not add the Requires: tag.

Updated package in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.