This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 896296 - Port polybori's use of PIL to support Pillow for F19
Port polybori's use of PIL to support Pillow for F19
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: polybori (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PILLOW
  Show dependency treegraph
 
Reported: 2013-01-16 19:28 EST by Toshio Ernie Kuratomi
Modified: 2013-01-21 18:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 18:26:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to use the form of import of PIL that is pillow compatible (726 bytes, patch)
2013-01-16 19:28 EST, Toshio Ernie Kuratomi
no flags Details | Diff

  None (edit)
Description Toshio Ernie Kuratomi 2013-01-16 19:28:08 EST
Created attachment 679942 [details]
Patch to use the form of import of PIL that is pillow compatible

Description of problem:

Fedora 19 is going to stop shipping python-imaging (PIL) and start shipping python-pillow instead.  Rationale can be found on the feature page: https://fedoraproject.org/wiki/Features/Pillow .  pillow should be compatible with PIL at the code level but the import statement changes slightly.

PIL supports both of these:

import Image

from PIL import Image

Pillow only supports the latter form.

I grepped through the polybori source and found some occurrences of "import Image".  I'll attach a patch that updates these to the new form of import.
Comment 1 Jerry James 2013-01-16 23:34:41 EST
Thanks for the patch.  Will a BR of python-imaging-devel and an R of python-imaging still be correct, or will they need to be changed too?
Comment 2 Toshio Ernie Kuratomi 2013-01-17 01:23:38 EST
The plan is to have python-pillow Provide python-imaging{-devel,-tk,etc} since the API is the same except for dropping the old method of importing.

You can update the package to use python-pillow and python-pillow-devel once those packages have replaced python-imaging in the repository if you like but it shouldn't be necessary for at least the next few releases.
Comment 3 Jerry James 2013-01-21 18:26:04 EST
I just rebuilt polybori in Rawhide with this patch, and forwarded the patch upstream.  Thanks, Toshio.

Note You need to log in before you can comment on or make changes to this bug.