This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 896385 - vdsm 6.4: Register rhev-h to RHEV-M ic 3.0 failed
vdsm 6.4: Register rhev-h to RHEV-M ic 3.0 failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Douglas Schilling Landgraf
Pavel Stehlik
infra
: Regression, ZStream
Depends On:
Blocks: 904857
  Show dependency treegraph
 
Reported: 2013-01-17 02:43 EST by haiyang,dong
Modified: 2013-02-25 14:07 EST (History)
16 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-1.3.el6
Doc Type: Bug Fix
Doc Text:
Red Hat Enterprise Virtualization Hypervisor requires a url that was used during the process of installing the hypervisor on the manager. This url allows the manager to detect the hypervisor. This url changed in the 3.2 development cycle, which caused the process of installing the hypervisor on the manager to fail. Unfortunately, in such cases, the manager reported that the hypervisor had been successfully registered into the rhevm network, but they hypervisor did not appear in the WebAdmin portal. A patch corrects the url required for the manager to detect the hypervisor during the installation process, and hypervisors now install on managers without problems related to incorrect urls.
Story Points: ---
Clone Of:
: 904857 (view as bug list)
Environment:
Last Closed: 2013-02-25 14:07:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached the vdsm-reg.log (587.39 KB, application/octet-stream)
2013-01-17 02:43 EST, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2013-01-17 02:43:44 EST
Created attachment 680050 [details]
attached the vdsm-reg.log

Description of problem:
After Installed rhev-h,then configure network and 
register to rhevm ic 3.0, Although rhev-h shown that register into rhevm success and the nic can rename "rhevm",but in fact didn't register.
Couldn't display rhevh host in rhevm web admin portal.

Also seen error info in /var/log/vdsm-reg/vdsm-reg.log 
MainThread::DEBUG::2013-01-17 03:10:45,544::deployUtil::144::root::
MainThread::DEBUG::2013-01-17 03:10:45,545::deployUtil::401::root::getHostID: 4C4C4544-0054-4D10-8038-C6C04F353358_78:2b:cb:9a:72:a3
MainThread::DEBUG::2013-01-17 03:10:45,545::vdsm-reg-setup::63::root::Setup::__init__ vars: {'vdcRegPort': '54321', 'ovirtUID': '4C4C4544-0054-4D10-8038-C6C04F353358_78:2b:cb:9a:72:a3', 'ovirtName': 'localhost.localdomain', 'fInitOK': True, 'registered': False, 'ovirtURL': '10.66.11.209', 'vdcName': '10.66.110.193', 'vdcPORT': '8443', 'VDCTime': None, 'ticket': '', 'vdcURI': '/OvirtEngineWeb/register', 'vdsmDir': '/usr/share/vdsm', 'vdcURL': '10.66.110.193'}
MainThread::DEBUG::2013-01-17 03:10:45,545::vdsm-reg-setup::66::root::validate start
MainThread::DEBUG::2013-01-17 03:10:45,546::vdsm-reg-setup::73::root::validate end. return: True
MainThread::DEBUG::2013-01-17 03:10:45,550::vdsm-reg-setup::180::root::execute start.
MainThread::DEBUG::2013-01-17 03:10:45,550::deployUtil::466::root::Bridge rhevm already exists.
MainThread::DEBUG::2013-01-17 03:10:45,550::vdsm-reg-setup::184::root::execute: found existing management bridge. Skipping rename.
MainThread::DEBUG::2013-01-17 03:10:45,550::deployUtil::1461::root::getRemoteFile start. IP = 10.66.110.193 port = 8443 fileName = "/engine.ssh.key.txt"
MainThread::DEBUG::2013-01-17 03:10:45,572::deployUtil::1498::root::/engine.ssh.key.txt status: 404 reason: Not Found
MainThread::ERROR::2013-01-17 03:10:45,573::deployUtil::1506::root::Failed to fetch /engine.ssh.key.txt status 404
MainThread::DEBUG::2013-01-17 03:10:45,573::deployUtil::1517::root::getRemoteFile end.
MainThread::DEBUG::2013-01-17 03:10:45,573::deployUtil::1461::root::getRemoteFile start. IP = 10.66.110.193 port = 8443 fileName = "/rhevm.ssh.key.txt"
MainThread::DEBUG::2013-01-17 03:10:45,592::deployUtil::1498::root::/rhevm.ssh.key.txt status: 200 reason: OK
MainThread::DEBUG::2013-01-17 03:10:45,592::deployUtil::1517::root::getRemoteFile end.
MainThread::DEBUG::2013-01-17 03:10:45,593::deployUtil::719::root::handleSSHKey start
MainThread::DEBUG::2013-01-17 03:10:45,593::deployUtil::748::root::handleSSHKey: persist authorized_keys
MainThread::DEBUG::2013-01-17 03:10:45,594::deployUtil::751::root::handleSSHKey end
MainThread::DEBUG::2013-01-17 03:10:45,594::vdsm-reg-setup::196::root::execute: after getAuthKeysFile: True
MainThread::DEBUG::2013-01-17 03:10:45,594::vdsm-reg-setup::114::root::registerVDS begin.
MainThread::DEBUG::2013-01-17 03:10:45,594::vdsm-reg-setup::124::root::registerVDS URI= /OvirtEngineWeb/register?vds_ip=10.66.11.209&__VIEWSTATE=&vds_unique_id=4C4C4544-0054-4D10-8038-C6C04F353358_78%3A2b%3Acb%3A9a%3A72%3Aa3&vds_name=localhost.localdomain&ticket=&port=54321

MainThread::DEBUG::2013-01-17 03:10:45,613::vdsm-reg-setup::155::root::registerVDS status: 404 reason: Not Found
MainThread::DEBUG::2013-01-17 03:10:45,613::vdsm-reg-setup::174::root::registerVDS end.
MainThread::DEBUG::2013-01-17 03:10:45,613::vdsm-reg-setup::201::root::execute: after registerVDS: False
MainThread::DEBUG::2013-01-17 03:10:45,613::vdsm-reg-setup::206::root::Registration status: False


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130109.1.auto1389.el6
vdsm-4.10.2-1.1.el6
rhevm-3.0.8_001-1.el6_3
I will try this case again after we get official rhevh build. 

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.4-20130109.1.auto1389.el6
2. Configure network for rhev-h
3. Register to rhevm ic 3.0.


Actual results:
After step3. Register to  rhevm ic 3.0 failed.

Expected results:
Supporting that register rhev-h to RHEV-M ic 3.0

Additional info:
Comment 5 haiyang,dong 2013-01-17 21:47:41 EST
Reproduce this bug on official rhevh build rhev-hypervisor6-6.4-20130116.3
Comment 6 RHEL Product and Program Management 2013-01-21 01:47:23 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 14 errata-xmlrpc 2013-02-25 14:07:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0555.html

Note You need to log in before you can comment on or make changes to this bug.