Bug 896445 - engine: shut down of vm during live migration will fail move action and vm's disk will be stuck in image locked
engine: shut down of vm during live migration will fail move action and vm's ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.2.0
Assigned To: Daniel Erez
Dafna Ron
storage
: Regression
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-01-17 05:26 EST by Dafna Ron
Modified: 2016-02-10 11:33 EST (History)
10 users (show)

See Also:
Fixed In Version: sf5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs from vm crash with wrong qemu and install of host (1.05 MB, application/x-gzip)
2013-01-17 05:26 EST, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11311 None None None Never

  None (edit)
Description Dafna Ron 2013-01-17 05:26:09 EST
Created attachment 680123 [details]
logs from vm crash with wrong qemu and install of host

Description of problem:

I had a vm that was doing a live move and I powered it off. 
the action was reported as failed and the vm's disk is stuck in image locked. 

Version-Release number of selected component (if applicable):

sf3


How reproducible:

100%

Steps to Reproduce:
1. start a live migration 
2. power off the vm
3.
  
Actual results:

move action will fail and the vm will be stuck in image locked

Expected results:

action should continue and vm's image should not be stuck in image locked 

Additional info:
Comment 1 Allon Mureinik 2013-01-23 05:02:19 EST
In order to complete the migration, the VM should be UP.
However, it is unreasonable to leave the disks in ImageLocked - we should, at the very least, fail gracefully.
Comment 2 Daniel Erez 2013-01-23 09:21:39 EST
The issue is only on live snapshot phase of live migration, i.e. powering off the VM during live snapshot creation (proposed fix is accordingly)
Comment 4 Dafna Ron 2013-02-03 07:38:04 EST
verified on sf5 

Failed to configure VM FFF with Live-Snapshot Auto-generated for Live Storage Migration. VM restart is recommended.
VM FFF powered off by admin@internal (Host: gold-vdsc).
Comment 5 Itamar Heim 2013-06-11 04:21:19 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 04:24:13 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.