Bug 896526 - quantum subnet --gateway option will be applied depand on its position in cli
quantum subnet --gateway option will be applied depand on its position in cli
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 08:46 EST by Ofer Blaut
Modified: 2013-01-21 11:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
python-quantum-2012.2.1-3.el6ost.noarch openstack-quantum-openvswitch-2012.2.1-3.el6ost.noarch python-quantumclient-2.1.10-1.el6ost.noarch openstack-quantum-2012.2.1-3.el6ost.noarch
Last Closed: 2013-01-21 11:58:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
subnet with gateway position (2.32 KB, text/plain)
2013-01-17 08:46 EST, Ofer Blaut
no flags Details

  None (edit)
Description Ofer Blaut 2013-01-17 08:46:18 EST
Created attachment 680209 [details]
subnet with gateway position

Description of problem:

In order to configure --gateway different than default ,
user  will use --gateway option.

When --gateway is used before CIDR in CLI it works,
When --gateway is used AFTER CIDR in CLI it DOESN'T work.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. quantum subnet-create  <Network ID> 27.1.1.0/24 --gateway 27.1.1.15 , gw 27.1.1.1 will be used by quantum 
2.quantum subnet-create  <Network ID> 26.1.1.0/24 --gateway 26.1.1.15 , gw 26.1.1.1 will be used by quantum 
3. According to API --gateway_ip should be used ???

example attached   
Actual results:


Expected results:


Additional info:
Comment 2 Gary Kotton 2013-01-21 11:58:28 EST
This is not a bug. Currently the CLI works in the following way: there are arguments that appear before mandatory parameters, for example the gateway that you hav mentioned above. Then there are parameters that can appear after the mandatory parameters. These for example are the actual values that are used internall - for example gateway_ip (http://wiki.openstack.org/QuantumV2APIIntro#Subnet)
It may be worthwhile opening a documentation bug on this issue.

Note You need to log in before you can comment on or make changes to this bug.