Bug 896536 - quantum dns_nameservers list=true option doesn't apear in CLI help neither in API
quantum dns_nameservers list=true option doesn't apear in CLI help neither in...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: RHOS Maint
Ofer Blaut
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 09:01 EST by Ofer Blaut
Modified: 2013-01-24 10:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-24 10:53:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
nameserver flag (1.52 KB, text/plain)
2013-01-17 09:01 EST, Ofer Blaut
no flags Details

  None (edit)
Description Ofer Blaut 2013-01-17 09:01:43 EST
Created attachment 680221 [details]
nameserver flag

Description of problem:

I was trying to create sunbet with dns server different than the DHCP ip.

according to API --dns_nameservers with ip address should be used .

CLI does provide any info about dns option .


This operation will fail unless using list=true flag 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.quantum  subnet-create --tenant-id<ID> <Network ID > 72.77.77.0/24 --dns_nameservers 14.14.14.14
2. repeat with list=true 
3. see example attached 
  
Actual results:


Expected results:

- dnsserver option should be added to CLI options
- list=true flag should not be in use 

Additional info:
Comment 2 Gary Kotton 2013-01-24 10:53:54 EST
This is not a bug. It is how the Quantum CLI works.

There are a number of ways of going about configuring and we should definitely update our documenttation of the CLI.

Note You need to log in before you can comment on or make changes to this bug.