Bug 896626 - Missing backuppc.service file after upgrade to 3.2.1-10 causes service to exit at start
Summary: Missing backuppc.service file after upgrade to 3.2.1-10 causes service to exi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: BackupPC
Version: 17
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Bernard Johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-17 16:15 UTC by Mike Lilley
Modified: 2013-02-03 13:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-03 13:42:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Mike Lilley 2013-01-17 16:15:55 UTC
Description of problem:
Since the file /usr/lib/systemd/system/backuppc.service doesn't exist, /var/run/BackupPC doesn't get created, and the backuppc service doesn't run.

Version-Release number of selected component (if applicable):
3.2.1-10

How reproducible:
I've only tried this once, as it happened on my single BackupPC server.

Steps to Reproduce:
1. Have running Fedora 17 x86_64 system with BackupPC 3.2.1-7 running on it.
2. Upgrade with yum update
3. Verify backuppc.service file is not created in /usr/lib/systemd/system, although the link in /etc/systemd/system/multi-user.wants is created.
  
Actual results:
/usr/lib/systemd/system/backuppc.service is missing.

Expected results:
/usr/lib/systemd/system/backuppc.service is installed.

Additional info:

Comment 1 Mike Lilley 2013-01-17 17:37:13 UTC
After removing 3.2.1-10 and re-installing it using yum, I find that the /usr/lib/systemd/system/backuppc.service file is missing in a new install, as well.

Downgrading to 3.2.1-7 installs the service definition file.

Comment 2 Mike Lilley 2013-01-17 21:49:44 UTC
And finally:

It appears that in this commit : http://pkgs.fedoraproject.org/cgit/BackupPC.git/commit/?h=f17&id=234f1cbfaaff48c5bf714644055723d5e71b23e0

You've removed the version checking of fedora for whether or not systemd is supported (as all supported versions now have systemd), and replaced it with the lines :

%if 0%{?rhel}
%global _with_tmpfilesd 0
%global _with_systemd 0
%endif

Note that those 2 globals are never assigned to 1 in the spec file, so I assume that they're undefined, and none of the checks against them ever succeed.  I assume a patch along these lines would fix the problem:

*** BackupPC.spec	2013-01-17 14:44:55.908689781 -0700
--- BackupPC.spec.fix	2013-01-17 14:46:33.008903727 -0700
***************
*** 7,12 ****
--- 7,16 ----
  %global _with_tmpfilesd 0
  %global _with_systemd 0
  %endif
+ %if 0%{?fedora}
+ %global _with_tmpfilesd 1
+ %global _with_systemd 1
+ %endif
  
  %global _updatedb_conf /etc/updatedb.conf

Comment 3 Bernard Johnson 2013-01-19 05:54:57 UTC
That's some bad logic for sure...

Comment 4 Johan Cwiklinski 2013-01-20 11:18:36 UTC
On my F-18, service seemed ok but was not, logging no error at all.

I've rebuild the package with globals set to 1; but then I had to disable and reenable the unit to have it working; bacause of this error: "Failed to get security context on /etc/rc.d/init.d/backuppc: No such file or directory"

Comment 5 Fedora Update System 2013-01-20 19:49:55 UTC
BackupPC-3.2.1-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/BackupPC-3.2.1-11.fc18

Comment 6 Fedora Update System 2013-01-20 20:00:37 UTC
BackupPC-3.2.1-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/BackupPC-3.2.1-11.fc17

Comment 7 Fedora Update System 2013-01-23 01:25:24 UTC
Package BackupPC-3.2.1-11.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing BackupPC-3.2.1-11.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1178/BackupPC-3.2.1-11.fc17
then log in and leave karma (feedback).

Comment 8 Mike Lilley 2013-01-23 16:52:36 UTC
Tested, works for me.  Thanks for the quick update.

Comment 9 Martin Wilck 2013-01-23 17:17:30 UTC
Works on F18, too.

Comment 10 Fedora Update System 2013-02-03 13:42:57 UTC
BackupPC-3.2.1-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-02-03 13:49:57 UTC
BackupPC-3.2.1-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.