Bug 896639 - systemd keeps starting NetworkManager
systemd keeps starting NetworkManager
Status: CLOSED DUPLICATE of bug 815243
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 11:33 EST by Karel Volný
Modified: 2013-01-17 17:24 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-17 11:58:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-01-17 11:33:55 EST
Description of problem:
I have some troubles using NetworkManager, so I need to stop it - just stop it, not to disable it completely. This deosn't work, systemd keeps starting it again and again and again ...

Version-Release number of selected component (if applicable):
systemd-197-1.fc18.1.x86_64

How reproducible:
always

Steps to Reproduce:
1. service NetworkManager stop
2. wait a few (tenths of) seconds
3. service NetworkManager status
  
Actual results:
NM is running

Expected results:
NM is not running

Additional info:
Comment 1 Michal Schmidt 2013-01-17 11:44:15 EST
Presumably a DBus client of NM causes its reactivation. Does it help if you disable just the DBus activation of NM?:
 rm /etc/systemd/system/dbus-org.freedesktop.NetworkManager.service
 systemctl daemon-reload
Comment 2 Pavel Šimerda (pavlix) 2013-01-17 11:58:26 EST

*** This bug has been marked as a duplicate of bug 815243 ***
Comment 3 Karel Volný 2013-01-17 17:24:50 EST
(In reply to comment #1)
> Presumably a DBus client of NM causes its reactivation. Does it help if you
> disable just the DBus activation of NM?:
>  rm /etc/systemd/system/dbus-org.freedesktop.NetworkManager.service
>  systemctl daemon-reload

bug #815243 comment #19 bullet 2) is the case, I don't want ugly workarounds ...

Note You need to log in before you can comment on or make changes to this bug.