Bug 89668 - When %_repackage_all_erasures is on importing a second gpg key generates a repackaged rpm
When %_repackage_all_erasures is on importing a second gpg key generates a re...
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-25 14:53 EDT by James Olin Oden
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 14:23:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Olin Oden 2003-04-25 14:53:31 EDT
Description of problem:
If you have %_repackage_all_erasures set to 1, and you have imported one 
gpg key into the database, ever importation of a gpg key thereafter will
generate a repackaged package with a name like:

        /var/TKLC/backout/pkg/gpg-pubkey-5072e1f5-3e3ea30c.(none).rpm

Rollbacks complain with a complaint of:

        error: failed to 
stat /view/crosson_dev_bcr_13681/vobs/software/platform: Stale NFS file handle

but they do seem to work.
   
Version-Release number of selected component (if applicable):

4.2-0.69

How reproducible:

every time.

Steps to Reproduce:
1.  Import a key.
2.  Import another key.
3.  Look in the %_repackage_dir.
    
Actual results:
You should find a repackaged package with the name gpg-pubkey.

Expected results:

No repackage of public keys.

Additional info:
Comment 1 Jeff Johnson 2003-04-29 13:10:08 EDT
Yes, gpg-pubkey packages can/will cause problems, because I
forgot to add a "noarch" tag.

Uncommenting

#ifdef  NOTYET
    (void) rpmdbSetIteratorRE(mi, RPMTAG_NAME, RPMMIRE_DEFAULT, '!gpg-pubkey');
#endif

in IDTXload() lib/rpminstall.c is probably needed as well, the
other place to fix is in lib/transaction.c where erasures are
repackaged, skipping packages named "gpg-pubkey".

All pending, awaiting a coherent repackage policy.
Comment 2 Paul Nasrat 2005-11-29 16:12:38 EST
James is this still valid against rpm 4.4.x branch?
Comment 4 Bill Nottingham 2007-01-02 14:23:04 EST
Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
f you are currently still running Red Hat Linux 7.3 or 9, you are strongly
advised to upgrade to a current Fedora Core release or Red Hat Enterprise Linux
or comparable. Some information on which option may be right for you is
available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.