Bug 89688 - fdisk false error message
fdisk false error message
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
http://www.math.tau.ac.il/~didi/editi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-25 19:40 EDT by acount closed by user
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-16 16:27:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2003-04-25 19:40:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
sometimes when it is made a new partition fdisk shows a message about it is
necesary reboot the system for to use the new fs. And this is not TRUE!!

--
[..fdisk shell...]
Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.

WARNING: Re-reading the partition table failed with error 16: Device or resource
busy.
The kernel still uses the old table.
The new table will be used at the next reboot.
Syncing disks.
---

it is possible to use partx for to solve this trouble
--partx--
/*
 * Given a block device and a partition table type,
 * try to parse the partition table, and list the
 * contents. Optionally add or remove partitions.
 *
 * [This is not an fdisk - adding and removing partitions
 * is not a change of the disk, but just telling the kernel
 * about presence and numbering of on-disk partitions.]
 *
 * Call:
 *	partx [-{l|a|d}] [--type TYPE] [--nr M-N] [partition] wholedisk
 * where TYPE is {dos|bsd|solaris|unixware|gpt}.
 *
 * Read wholedisk and add all partitions:
 *	partx -a wholedisk
 *
 * Subdivide a partition into slices (and delete or shrink the partition):
 * [Not easy: one needs the partition number of partition -
 *  that is the last 4 or 6 bits of the minor; it can also be found
 *  in /proc/partitions; but there is no good direct way.]
 *	partx -a partition wholedisk
 *
 * Delete all partitions from wholedisk:
 *	partx -d wholedisk
 *
 * Delete partitions M-N from wholedisk:
 *	partx -d --nr M-N wholedisk
 *
 * aeb, 2000-03-21 -- sah is 42 now
 */
--end--

I dont know about sfdisk, but this false reboot message must be changed by other
!!! 

more info here:
http://www.math.tau.ac.il/~didi/editing-busy-partition-tables.html
to

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fdisk
2.to add one partition and :w
3.reboot? NO
    

Additional info:
Comment 1 acount closed by user 2003-05-14 22:30:49 EDT
redhat 9 has the same problem, maybe the new version 2.11z is ok :-?
Comment 2 Elliot Lee 2003-05-16 16:27:40 EDT
If you use partx, this message does not appear. When you use fdisk, this message is valid 
because of the way fdisk is implemented. Until fdisk's implementation changes to not 
require a reboot, the message will stay. I cannot say if/when fdisk's implementation will 
change, although I agree it would be a useful feature in the future.

Note You need to log in before you can comment on or make changes to this bug.