Bug 89701 - german umlauts not displayed correctly
german umlauts not displayed correctly
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kde-i18n (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-26 03:58 EDT by Christian Paratschek
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Paratschek 2003-04-26 03:58:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3) Gecko/20030314

Description of problem:
first of all: i have checked bugzilla and found various bugs regarding german
umlauts. still, i couldn't find it the way i am experiencing it.
i choose component "kde-i18n", but this is probably not true. the problem shows
up in all programs (gnome-terminal, nautilus, konqueror, to name the most prominent)

ok, IMPORTANT: while i preview this bug right now i see, that the umlauts are
not displayed here in the description box. so, for the rest of this document, i
use the html-encoding: whenever you see ö - i really mean the german umlaut
o. i reported the bug while i am running redhat 9, that means i am experiencing
it while i write about it. awful :-)

ok, here goes:
i use ms windows and red hat linux on the same computer, with a fat32-partition
in the middle for data exchange. when i create a file (let's call it ���ö
öö.txt) under windows, it shows up as "???.txt (Unicode ungü
�ltig)" under redhat. vice versa, when i create a file called �üü
ü��.txt under redhat, it shows up under windows incorrectly (with some
squares instead of the umlauts). i can, however, create files with umlauts with
redhat and use them just perfectly as long as i only use them under linux.

another aspect of the problem: i recently set up a redhat8 server for file
sharing purposes (small network with 2 windows xp clients). i set up samba and
then copied the files the company gave me (they were burned on a cd-rom). the
only way i could transfer the files to the redhat-server was, putting the cd
into one of the windows clients and copy the files from there to the server.
when i opened a filemanager then on the server, i saw the usual bugged umlauts,
but that didn't matter, because the files would only be opened on the windows
clients where they were displayed correctly. i could, however, not copy the
files from the cd to the share via the servers cdrom drive because it would
again screw the umlauts up, also for the windows machines... 

it is said that this is a problem with utf-8. well, i just wanna say that it's a
showstopper for me. i use redhat linux a lot, at home almost exclusively and i
have also installed it in several companies (i am an it-support). dualbooting
between windows and linux is very common nowadays and even if someone is not
using windows at all, he will probably experience the problem when exchanging
data with someone who does use windows...

best regards,
christian 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create a file with german umlauts in windows or linux
2. view the file in a filemanager/shell in the other operating system
3.
    

Actual Results:  ���ö%ouml;ö.txt (created with windows xp) got
displayed as ???.txt (unicode ung�ltig) in linux
���ü%uuml;%uuml;.txt (created with redhat 9) got displayed as *+:.txt in
windows (not exactly, it was more like, squares...) 

Expected Results:  well, obviously the files should have correct names...

Additional info:
Comment 1 Miloslav Trmac 2003-04-26 13:13:06 EDT
man mount to configure character set translation for the fat32 partition.
Comment 2 Christian Paratschek 2003-04-30 13:48:47 EDT
ok, i found the solution to the problem: it is already mentioned in another bug
report here:
edit /etc/sysconfig/i18n:
change the line: lang="de_DE:utf-8" to lang="de_DE"

it is not, like mentioned above, an issue that's connected to mounting options
for fat32-partitions. after editing /etc/sysconfig/i18n, it is perfectly
possible to use a fat-partition mounted just with "vfat auto,uid=500".

this fix solves the problem almost completely (umlauts show up in redhat, files
with umlauts can be created and viewed with both operating systems).
this bug seems to be a minor issue technically but it is a major annoyance to
german speaking redhat-users.

on another note: this fix doesn't solve the problem completely:
when i connect to another windows machine via nautilus and smb:///, i also
discover this bug. it does, however, not show up, when i browse the same share
with konqueror, so there could also be some gnome-related problem. but i am just
guessing :-)

regards,
christian

p.s.: sorry for changing my account. something screwed up and i could neither
log in with my other email nor get my password resent to me...
Comment 3 Petr Rockai 2006-07-17 14:17:56 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 4 Bill Nottingham 2006-10-18 13:59:52 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.