Bug 89705 - Choice of levels in contour plot is impossible
Choice of levels in contour plot is impossible
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: octave (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
http://www.octave.org/mailing-lists/h...
:
: 89704 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-26 06:55 EDT by Niels L Ellegaard
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 12:35:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels L Ellegaard 2003-04-26 06:56:13 EDT
Description of problem:


Version-Release number of selected component (if applicable):
GNU Octave, version 2.1.36
(Solved in later versions of Octave)

How reproducible:
100%

Steps to Reproduce:
octave:1> x = y = [0:0.01:2];
octave:2> z = sin(x' * y);
octave:3> contour(x,y,z,[1:1:15])
    
Actual results:
Only 10 contour lines appear

Expected results:
15 contour lines appear

Additional info:
Comment 1 Niels L Ellegaard 2003-04-26 07:00:33 EDT
The url contains all the information. The problem seems to be caused because
there sprintf cannot handle large strings. This is a problem as octave sends the
levels to gnuplot as a string. In the process some levels are forgotten.
Comment 2 Lon Hohberger 2003-04-28 11:27:39 EDT
*** Bug 89704 has been marked as a duplicate of this bug. ***
Comment 3 Lon Hohberger 2003-04-28 12:35:48 EDT
The noted behavior does indeed occur in 2.1.36, but does not in 2.1.40, which
shipped with Red Hat Linux 9.  The Red Hat Linux 9 RPM is available from:

ftp://ftp.redhat.com/pub/redhat/linux/9/en/os/i386/RedHat/RPMS/octave-2.1.40-4.i386.rpm

and should work fine on an installed 8.0 system (I upgraded an installed 8.0
system's octave package to the above package).

[root@water root]# octave
GNU Octave, version 2.1.40 (i386-redhat-linux-gnu).
Copyright (C) 1996, 1997, 1998, 1999, 2000, 2001, 2002 John W. Eaton.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTIBILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type `warranty'.

Please contribute if you find this software useful.
For more information, visit http://www.octave.org/help-wanted.html

Report bugs to <bug-octave@bevo.che.wisc.edu>.

octave:1> x = y = [0:0.01:2];
octave:2> z = sin(x' * y);
octave:3> contour(x,y,z,[1:1:15])
tmp = 1.000000, 2.000000
tmp = 1.000000, 2.000000, 3.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000, 8.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000,
8.000000, 9.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000,
8.000000, 9.000000, 10.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000,
8.000000, 9.000000, 10.000000, 11.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000,
8.000000, 9.000000, 10.000000, 11.000000, 12.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000,
8.000000, 9.000000, 10.000000, 11.000000, 12.000000, 13.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000,
8.000000, 9.000000, 10.000000, 11.000000, 12.000000, 13.000000, 14.000000
tmp = 1.000000, 2.000000, 3.000000, 4.000000, 5.000000, 6.000000, 7.000000,
8.000000, 9.000000, 10.000000, 11.000000, 12.000000, 13.000000, 14.000000, 15.000000
command = gset cntrparam levels discrete 1.000000, 2.000000, 3.000000, 4.000000,
5.000000, 6.000000, 7.000000, 8.000000, 9.000000, 10.000000, 11.000000,
12.000000, 13.000000, 14.000000, 15.000000
octave:4> 


Note You need to log in before you can comment on or make changes to this bug.