Bug 8971 - RPMs of foreign language HOWTOs appear to be uninstallable
RPMs of foreign language HOWTOs appear to be uninstallable
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: howto (Show other bugs)
6.1
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-29 20:20 EST by George Moody
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 22:03:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Moody 2000-01-29 20:20:47 EST
Following a clean "install everything" installation of Red Hat Linux 6.1,
try this:

# rpm -qa | grep howto
howto-6.1-1
howto-chinese-6.1-1
howto-croatian-6.1-1
howto-french-6.1-1
howto-german-6.1-1
howto-greek-6.1-1
howto-html-6.1-1
howto-indonesian-6.1-1
howto-italian-6.1-1
howto-japanese-6.1-1
howto-korean-6.1-1
howto-polish-6.1-1
howto-russian-6.1-1
howto-serbian-6.1-1
howto-sgml-6.1-1
howto-slovenian-6.1-1
howto-spanish-6.1-1
howto-swedish-6.1-1
howto-turkish-6.1-1

Now try:

# rpm -ql howto-french
/usr/doc/HOWTO
/usr/doc/HOWTO/translations
/usr/doc/HOWTO/translations/fr
/usr/doc/HOWTO/translations/fr/3Dfx-HOWTO
/usr/doc/HOWTO/translations/fr/Access-HOWTO
/usr/doc/HOWTO/translations/fr/Alpha-HOWTO
/usr/doc/HOWTO/translations/fr/Assembly-HOWTO
/usr/doc/HOWTO/translations/fr/Benchmarking-HOWTO
... [snip] ...

Now try:

# ls -l /usr/doc/HOWTO/translations
ls: /usr/doc/HOWTO/translations: No such file or directory

All attempts to (re)install the foreign language HOWTO from
the RPMs on the RHL 6.1 CD-ROM fail -- rpm -Uvh or rpm -ivh
report that the packages are already installed. rpm -e marks
them as uninstalled, but a fresh attempt to install them
looks like this example:

# rpm -e howto-french
# rpm -ivvh howto-french-6.1-1.noarch.rpm
D: counting packages to install
D: found 1 packages
D: looking for packages to download
D: retrieved 0 packages
D: New Header signature
D: Signature size: 149
D: Signature pad : 3
D: sigsize         : 152
D: Header + Archive: 10036496
D: expected size   : 10036496
D: opening database mode 0x42 in //var/lib/rpm/
D: found 0 source and 1 binary packages
D: installing binary packages
D: getting list of mounted filesystems
D: New Header signature
D: Signature size: 149
D: Signature pad : 3
D: sigsize         : 152
D: Header + Archive: 10036496
D: expected size   : 10036496
D: package: howto-french-6.1-1 files test = 0
D:    file: /usr/doc/HOWTO action: skipnstate
D:    file: /usr/doc/HOWTO/translations action: skipnstate
D:    file: /usr/doc/HOWTO/translations/fr action: skipnstate
D:    file: /usr/doc/HOWTO/translations/fr/3Dfx-HOWTO action: skipnstate
D:    file: /usr/doc/HOWTO/translations/fr/Access-HOWTO action: skipnstate
D:    file: /usr/doc/HOWTO/translations/fr/Alpha-HOWTO action: skipnstate
... [snip] ...

... and after the dust settles, none of the files have been installed,
although the RPM database has been updated and rpm will once again report
that the package has been installed.  The same thing happens with any of
the other foreign language HOWTO RPMs.

Am I missing something obvious, or are these RPMs uninstallable?
Comment 1 Cristian Gafton 2000-02-03 22:03:59 EST
LANG needs to be set to fr_FR before those files get dumped on the hard drive.
Those files are tagged as being usefull only for LANG=fr_FR setups.
Comment 2 George Moody 2000-02-04 09:04:59 EST
Sounds like you need a HOWTO on the subject of how to install HOWTOs :-)
Seriously, how is anyone supposed to be able to figure this out, especially
if they don't have the documentation?  It seems like a bad idea to place
obstacles, particularly undocumented obstacles, in the way of installing (of all
things) documentation!  In a multilingual environment, one of the attractive
features of Linux is that reasonably decent documentation is available in
languages other than English.

I would guess that this was probably done so that folks who do "everything"
installs don't get their disks unnecessarily cluttered with many megabytes of
files they may never use.  The '--force' option of rpm, however, *should*
override requirements such as LANG=... (but this is not the case), and the
the '-vv' option *should* result in a display of exactly what condition was not
satisfied (but it doesn't).  Perhaps rpm -vv can emit a diagnostic:
   Package 'foo' cannot be installed unless you set the value of environment
   variable 'BAR' to 'blurfl'

Note You need to log in before you can comment on or make changes to this bug.