Bug 89716 - Optical Scsi disk drives upset disk numbering
Summary: Optical Scsi disk drives upset disk numbering
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-26 18:05 UTC by c.m.western
Modified: 2014-03-17 02:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 15:46:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description c.m.western 2003-04-26 18:05:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The disk numbering generated by updfstab is wrong in the presence of optical
disks, as it seems these are counted in the same way as hard disks by the kernel
but ignored by kudzu

Version-Release number of selected component (if applicable):
kudzu-0.99.69-1

How reproducible:
Always

Steps to Reproduce:
1.Install optical scsi disk drive
2.Install removable USB hard-disk
3.updfstab
    

Additional info:

The device that causes the problem is:
Host: scsi0 Channel: 00 Id: 02 Lun: 00
  Vendor: MATSHITA Model: PD-1 LF-1000     Rev: A105
  Type:   Optical Device                   ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 02 Lun: 01
  Vendor: MATSHITA Model: PD-1 LF-1000     Rev: A105
  Type:   CD-ROM                           ANSI SCSI revision: 02

The following patch works for me:

--- ./scsi.c.orig       2003-02-13 21:48:53.000000000 +0000
+++ ./scsi.c    2003-04-26 18:15:44.000000000 +0100
@@ -493,7 +493,7 @@
                }

                newdev = scsiNewDevice(NULL);
-               if (strstr(start, "Direct-Access")) {
+               if (strstr(start, "Direct-Access") || strstr(start,"Optical
Device")) {
                    newdev->class = CLASS_HD;
                } else if (strstr(start, "Sequential-Access")) {
                    newdev->class = CLASS_TAPE;

Comment 1 Bill Nottingham 2003-04-28 15:46:15 UTC
Added, will be in 1.1.4-1.


Note You need to log in before you can comment on or make changes to this bug.