Bug 89718 - Magicdev significantly slows down disk speed
Summary: Magicdev significantly slows down disk speed
Status: CLOSED DUPLICATE of bug 73661
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: magicdev (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-26 19:18 UTC by Nadeem
Modified: 2007-04-18 16:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nadeem 2003-04-26 19:18:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
Enabling magicdev significantly slows down disk access. That is, leaving
magicdev running to poll for music cds or to auto-mount data CDS, has a major
impact on the performance of the harddrive.  

I have a Dell Inspiron 8200 laptop. P4 2.2GHz with an IBM 5400 RPM 40 gig hd. 
the hard drive is hda and a dvd/cdrw is hdb. Hdb is set to ide-scsi so the
burner can be used. 

Leaving magicdev on, hdparm reports disk speeds of 14-18 meg/sec.
However, the disk feels significantly slower than that. Programs like mozilla
and openoffice take upwards of a minute to run. With magicdev shutoff, hdparm
consistantly reports a disk speed of 26 meg/sec. Moreover, application loading
is snappy. 

This bug/feature of magicdev is not well documented, I've had this problem for
months before I accidentily stumbled upon someone else encountering the same
problem and recommending to kill magicdev. Before, I assumed the kernel was not
correctly dealing with my IDE controller, and i'd need to upgrade the kernel to
fix disk speed (which I was giong to get around to in the summer). 

Version-Release number of selected component (if applicable):
RedHat 9.0, magicdev-1.1.4-4

How reproducible:
Always

Steps to Reproduce:
1. Enable MagicDev
2.
3.
    

Actual Results:  Slow Disk Speed

Expected Results:  Disk speed remains constant

Additional info:

Comment 1 Sean Whitacre 2003-05-01 04:10:56 UTC
I am experiencing the same problem on a Dell M50 with a Western Digital 40GB 
IDE drive. I'm running redhat 7.2. When executing "hdparm -tT </dev/hdX>" with 
magicdev running I get disk reads of 1-2MB's/sec. When I kill magicdev disk 
reads go up to and are consistant at 22MB's/sec. Until a better solution is 
found I am going to remove the magicdev package and enable automount for the 
cdrom and floppy devices.

Comment 2 Owen Taylor 2003-05-01 20:42:44 UTC
The interesting question here is really the exact model of the CD-ROM involved
(though that is less of a sensible question for the laptop). The basic problem 
here is that the CD-ROM doesn't respond properly to magicdev's probe and that
screws up the bus for some period of time.

(Note that if you can possibly put your CD-ROM on a different IDE channel
than your hard drive, you'll be better off)

*** This bug has been marked as a duplicate of 73661 ***

Comment 3 Gunther Mayer 2006-02-20 14:51:33 UTC
The root-cause might be related to 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179573,
but there is not enough data above to be sure.

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.