This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 89726 - rpm or up2date fail with database needs to be recovered error
rpm or up2date fail with database needs to be recovered error
Status: CLOSED DUPLICATE of bug 88720
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-26 18:06 EDT by Peter Baitz
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Baitz 2003-04-26 18:06:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I installed the full 3 CD's of Red Hat Linux 9.0
When I do rpm updates to up2date it seems the rpm
database gets corrupted or something and I wind
up rebooting and trying again or running rpm --rebuilddb
I had install reformat all the paritions for this install
of RHL 9.0 and I was only able to update errata by
downloading it then using rpm -Uvh ... luckily after
many tries got it all updated.


Version-Release number of selected component (if applicable):
rpm-4.2-0.69  kernel-2.4.20-9

How reproducible:
Sometimes

Steps to Reproduce:
1. try to do rpm -U  or an up2date
2. complains the database needs to be recovered

    

Actual Results:  rpm or up2date fail
with rpm database error
complains the database needs to be recovered


Expected Results:  should work fine

Additional info:

I will post the actual result next time it occurs. Should be soon.
Comment 1 Peter Baitz 2003-04-26 18:33:26 EDT
Please note this same PC has Red Hat Linux 7.3 on it before I wiped the disks
and installed 9.0 from scratch, reformatting all paritions.  I had ZERO issues
with rpm under 7.3.   

Also, it seems rpm is a bit slow with 4.9gb of packages installed.  The
"Prepare" phase takes a fairly long time even for one rpm update.

Comment 2 Barry K. Nathan 2003-04-26 23:28:13 EDT
You could try installing RPM 4.2-1 from here:

ftp://ftp.rpm.org/pub/rpm/test-4.2/

Whenever I install RH 9, this is the first thing I do once I get past the
firstboot wizard. This newer version of RPM 4.2 isn't perfect, but it's far far
better than what ships with RH 9.
Comment 3 Jeff Johnson 2003-04-29 13:40:43 EDT
Yes, you want rpm-4.2-1 as mentioned.

Please reopen this bug if you have further problems.
Comment 4 Peter Baitz 2003-05-19 22:10:43 EDT
I just tried to run up2date --update --force, and it errors out with chatter
that looks like this:

#########################################################
2.3)', None), 0, None, 0), (('xinetd', '2.3.11', '1.9.0'), ('libcrypt.so.1',
None), 0, None, 0), (('xinetd', '2.3.11', '1.9.0'), ('libm.so.6', None), 0,
None, 0), (('xinetd', '2.3.11', '1.9.0'), ('libnsl.so.1', None), 0, None, 0),
(('xinetd', '2.3.11', '1.9.0'), ('libwrap.so.0', None), 0, None, 0), (('xinetd',
'2.3.11', '1.9.0'), ('setup', None), 0, None, 0)]
There was a package dependency problem. The message was:
Dependencies should have already been resolved, but they are not.
rpmdb: fatal region error detected; run recovery
error: db4 error(-30982) from db->close: DB_RUNRECOVERY: Fatal error, run
database recovery
rpmdb: fatal region error detected; run recovery
error: db4 error(-30982) from db->close: DB_RUNRECOVERY: Fatal error, run
database recovery
rpmdb: fatal region error detected; run recovery
error: db4 error(-30982) from db->close: DB_RUNRECOVERY: Fatal error, run
database recovery
rpmdb: fatal region error detected; run recovery
####################################################

And now (before any reboot) rpm is again flaking out like this:

####################################################
[root@boaz boot]# rpm -q rpm
rpmdb: fatal region error detected; run recovery
error: db4 error(-30982) from dbenv->open: DB_RUNRECOVERY: Fatal error, run
database recovery
error: cannot open Packages index using db3 -  (-30982)
error: cannot open Packages database in /var/lib/rpm
package rpm is not installed
####################################################

Probably a reboot will fix the rpm flakiness, but good thing it did not
half-bake install some rpms and not others or this would be a nightmare.

PLEASE REOPEN.   RPM v4.2-1 which you (Redhat) recommended I install
is also unstable.

Comment 5 Peter Baitz 2003-05-20 18:41:31 EDT
I rebooted, and since the up2date had downloaded all the rpm's I ram an rpm -Uvh
on them, but RPM wound up timing out and stopped responding. I had to kill it
and would have to reboot AGAIN and try again, and just maybe rpm will become
more responsive, but it seems hit and miss now.
Comment 6 Jeff Johnson 2003-06-25 12:53:36 EDT
I doubt that this specific problem is reproducible, but
just in case, adding to the DB_PAGE_NOTFOUND pile

*** This bug has been marked as a duplicate of 88720 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:52:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.