Bug 89728 - Konqueror web browser crashes on certain URLs
Konqueror web browser crashes on certain URLs
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-26 18:45 EDT by Xander D Harkness
Modified: 2016-06-07 18:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-29 11:10:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xander D Harkness 2003-04-26 18:45:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4a) Gecko/20030401

Description of problem:
Visiting http://www.phynd.org crashes konqueror.

If the application is set up on a local network then it also crashes on the home
page.

Version-Release number of selected component (if applicable):
konqueror 3.1-12 Red Hat (using KDE 3.1-10 Red Hat)

How reproducible:
Always

Steps to Reproduce:
1.Open konqueror
2. Browse to http://www.phynd.org
3. Get debugging signals as it crashes :-)
    

Actual Results:  I get a crash report from Konqueror every time.

Expected Results:  The requested location should open as a web site.

Additional info:

(no debugging symbols found)...(no debugging symbols found)...[New Thread
1092512800 (LWP 4855)]
(no debugging symbols found)...0xffffe002 in ?? ()
#0  0xffffe002 in ?? ()
#1  0x406375bd in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x418af05a in DOM::StyleBaseImpl::parseValue(QChar const*, QChar const*,
int) () from /usr/lib/libkhtml.so.4
#4  0x418ac1a1 in DOM::StyleBaseImpl::parseProperty(QChar const*, QChar const*)
    () from /usr/lib/libkhtml.so.4
#5  0x418ac2f1 in DOM::StyleBaseImpl::parseProperties(QChar const*, QChar
const*) () from /usr/lib/libkhtml.so.4
#6  0x418b14ef in DOM::StyleBaseImpl::parseStyleRule(QChar const*&, QChar
const*) () from /usr/lib/libkhtml.so.4
#7  0x418b1636 in DOM::StyleBaseImpl::parseRule(QChar const*&, QChar const*) ()
   from /usr/lib/libkhtml.so.4
#8  0x418a3106 in DOM::CSSStyleSheetImpl::parseString(DOM::DOMString const&,
bool) () from /usr/lib/libkhtml.so.4
#9  0x4184c89c in DOM::HTMLLinkElementImpl::setStyleSheet(DOM::DOMString const&,
DOM::DOMString const&) () from /usr/lib/libkhtml.so.4
#10 0x418c0fad in khtml::CachedCSSStyleSheet::checkNotify() ()
   from /usr/lib/libkhtml.so.4
#11 0x418c0f03 in khtml::CachedCSSStyleSheet::data(QBuffer&, bool) ()
   from /usr/lib/libkhtml.so.4
#12 0x418c59f1 in khtml::Loader::slotFinished(KIO::Job*) ()
   from /usr/lib/libkhtml.so.4
#13 0x418c80f8 in khtml::Loader::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkhtml.so.4
#14 0x409b80c9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#15 0x401767d2 in KIO::Job::result(KIO::Job*) () from /usr/lib/libkio.so.4
#16 0x40162857 in KIO::Job::emitResult() () from /usr/lib/libkio.so.4
#17 0x40163dae in KIO::SimpleJob::slotFinished() () from /usr/lib/libkio.so.4
#18 0x401666be in KIO::TransferJob::slotFinished() () from /usr/lib/libkio.so.4
#19 0x40177fcd in KIO::TransferJob::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkio.so.4
#20 0x409b80c9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#21 0x409b7f6d in QObject::activate_signal(int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#22 0x4015900e in KIO::SlaveInterface::finished() () from /usr/lib/libkio.so.4
#23 0x40157e1d in KIO::SlaveInterface::dispatch(int, QMemArray<char> const&) ()
   from /usr/lib/libkio.so.4
#24 0x401574c9 in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.4
#25 0x4015511b in KIO::Slave::gotInput() () from /usr/lib/libkio.so.4
#26 0x40156bd0 in KIO::Slave::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkio.so.4
#27 0x409b80c9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#28 0x409b81a5 in QObject::activate_signal(int, int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#29 0x40c98282 in QSocketNotifier::activated(int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#30 0x409d44b0 in QSocketNotifier::event(QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#31 0x40959f24 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#32 0x40959b19 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#33 0x405cb1e9 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#34 0x40934efa in QEventLoop::activateSocketNotifiers() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#35 0x409128d7 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#36 0x4096dcf6 in QEventLoop::enterLoop() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#37 0x4096db98 in QEventLoop::exec() () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#38 0x4095a151 in QApplication::exec() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#39 0x4129e3e7 in main () from /usr/lib/konqueror.so
#40 0x0804ca81 in strcpy ()
#41 0x0804d73b in strcpy ()
#42 0x0804dbec in strcpy ()
#43 0x0804e8f9 in strcpy ()
#44 0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6
Comment 1 Ngo Than 2003-04-29 11:10:04 EDT
i cannot reproduce it on RHL 9. it works for me

Note You need to log in before you can comment on or make changes to this bug.