Bug 8973 - /usr/include/scsi belongs to glibc-devel pkg and isn't a link to kernel includes.
Summary: /usr/include/scsi belongs to glibc-devel pkg and isn't a link to kernel inclu...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-30 04:22 UTC by Chuck Powell
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 19:24:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chuck Powell 2000-01-30 04:22:17 UTC
I'm not sure if this is a bug/missconfiguration issue but I've just run
across it after an upgrade to 2.2.14.

	After moving from kernel 2.2.13 to 2.2.14 I tried to recompile something
else and it couldn't find the /usr/include/asm stuff.  This is reported in
bug #7574.  (symlink: /usr/include/asm is pointing at
/usr/src/linux/include/asm rather than asm-i386)  Looking at the other
links in /usr/include that I understand should be symlinks to kernel
includes I find that /usr/include/linux is a symlink pointing to the right
target but /usr/include/scsi is not.  /usr/include/scsi is a directory
containing 2 header files and it belongs to the glibc-devel-2.1.2-11 pkg
rather than being a symlink to /usr/src/linux/include/scsi.

	I may be completely mixed up (I'm not a linux guru.) but shouldn't
/usr/include/asm,linux,scsi be symlinks to the corresponding kernel
includes?  Why isn't /usr/include/scsi a symlink to the kernel includes?
(belonging to the kernel-headers pkg)

	I would like to just delete /usr/include/scsi and recreate it as a symlink
to the kernel includes but I'm not sure if I'll break something important
by doing so.  I wonder because the kernel scsi include dir contains the
files 'scsi.h, scsi_ioctl.h, scsicam.h, and sg.h' where the glibc-devel
supplied dir contains only 2 headers 'scsi.h and sg.h'.

	System is RH 6.1 w/relevant errata updates on a PII333.  Yes I have
/usr/src/linux as a symlink pointing at the correct current kernel src.  ;)

Comment 1 Bill Nottingham 2000-02-05 19:24:59 UTC
This is intentional; glibc-devel contains some generic not-kernel-specific
scsi headers.


Note You need to log in before you can comment on or make changes to this bug.