Bug 89735 - redhat-config-soundcard crashes
redhat-config-soundcard crashes
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-soundcard (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-27 01:30 EDT by David Penton
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-01 15:14:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Penton 2003-04-27 01:30:47 EDT
Description of problem:

redhat-config-soundcard crashes with a cryptic message.

Version-Release number of selected component (if applicable):

N/A

How reproducible:

run redhat-config-soundcard in terminal with bash

Steps to Reproduce:
 (see above)
    
Actual results:

Traceback (most recent call last):
  File "/usr/share/redhat-config-soundcard/redhat-config-soundcard.py", line 44,
in ?
    app = soundcard.childWindow()
  File "/usr/share/redhat-config-soundcard/soundcard.py", line 162, in __init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list

Expected results:

? it should not crash

Additional info:
Comment 1 Brent Fox 2003-05-20 15:09:22 EDT
What are the contents of /etc/modules.conf?

Also, try this:
1) log in as root
2) run 'python'
3) type 'import kudzu'
4) type 'list = kudzu.probe(kudzu.CLASS_AUDIO, kudzu.BUS_PCI, kudzu.PROBE_ALL)'
5) type 'print list'

What is the output of step 5?
Comment 2 David Penton 2003-05-20 18:30:58 EDT
I am running the alsa driver for a Delta 66 card + onboard sound for motherboard 
ASUS P4PE.  I did not get this error before, but I may be doing something
different after installing kernel 2.4.20-9 from RH.

Here is my /etc/modules.conf:

alias usb-controller ehci-hcd
alias usb-controller1 usb-uhci
alias ieee1394-controller ohci1394
alias eth0 bcm4400
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-ice1712
# module options should go here
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias sound-slot-1 snd-ice1712
post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :


I tried:

1) log in as root
2) run 'python'
3) type 'import kudzu'
4) type 'list = kudzu.probe(kudzu.CLASS_AUDIO, kudzu.BUS_PCI, kudzu.PROBE_ALL)'
5) type 'print list'


I did the above and got this as the output of step 5:

[Desc:           Intel Corp.|82801DB AC'97 Audio
Driver:         i810_audio
Device:         None
, Desc:           IC Ensemble Inc|ICE1712 [Envy24]
Driver:         snd-ice1712
Device:         None
]





Comment 3 Brent Fox 2003-05-21 16:27:05 EDT
I have not tested redhat-config-soundcard with the ALSA drivers, but I can tell
you that having two different lines in /etc/modules.conf that begin 'alias
sound-slot-0' is what is causing redhat-config-soundcard to crash.  

Try removing that line from the file and then seeing if it works.  Note: dont'
just comment the line out...remove it.  My parser isn't ignoring commented lines
but I'm fixing this now.  

Does that make things work?
Comment 4 Brent Fox 2003-07-01 15:14:35 EDT
Closing due to lack of information.  

Note You need to log in before you can comment on or make changes to this bug.