Bug 89736 - rpm -q sometimes outputs indecisive silence
rpm -q sometimes outputs indecisive silence
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
http://math.uci.edu/~bnathan/.vlr/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-27 01:50 EDT by Barry K. Nathan
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 13:46:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2003-04-27 01:50:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030313

Description of problem:
With the test-4.1.1 or test-4.2 RPMs under RH 8.0 or 9, rpm -q sometimes exits
silently rather than listing the package or saying it's not installed. This does
not happen with RPM 4.0.4 or test-4.0.5. Unlike bug 89734, the presence or
absence of NPTL (e.g. with LD_ASSUME_KERNEL) does not prevent the bug from being
reproduced.

Version-Release number of selected component (if applicable):
rpm-4.2-1

How reproducible:
Depends on how fast you can slam the Up Arrow and Enter keys on your keyboard... :/

Steps to Reproduce:
1. Run the following command/shell script as root (changing the kernel-utils RPM
filename as necessary):
 while : ; do rpm -e --justdb kernel-utils ; rpm -i
--justdb kernel-utils-2.4-8.29.i386.rpm ;done

2. In a second console, repeatedly run the command "rpm -q kernel-utils". After
you run the command the first time, you may want to alternately press the up
arrow key with your right hand and the enter key with your left hand, very
quickly. You may need to do this a few dozen times, although the faster you do
it the fewer times you'll need to do it.

3. If two shell prompt lines appear without any intervening output from RPM, the
bug has been reproduced. (See the "Actual Results" for an example.)

Actual Results:  Snippet of output:

[barryn@localhost barryn]$ rpm -q kernel-utils
kernel-utils-2.4-8.29
[barryn@localhost barryn]$ rpm -q kernel-utils
package kernel-utils is not installed
[barryn@localhost barryn]$ rpm -q kernel-utils
[barryn@localhost barryn]$ rpm -q kernel-utils
package kernel-utils is not installed
[barryn@localhost barryn]$

Expected Results:  When rpm -q shirks its responsibilities, I'd like to know
why. (RPM 4.0.4 and test-4.0.5, for instance, sometimes display database lock
errors in response to rpm -q which make it clear that the database was locked by
another RPM instance.)

Additional info:
As with bug 89734, I can't think of any major consequences of this bug, but it
might have larger implications that I'm not aware of.
Comment 1 Barry K. Nathan 2003-04-27 03:53:05 EDT
http://math.uci.edu/~bnathan/.vlr/

Inside that directory is "vlr3", a copy of /var/lib/rpm which is corrupted in
such a way that "rpm -q kernel-utils" *always* responds with silence. (This is
actually the result of a failed attempt to reproduce bug 89738.)
Comment 2 Lee Killough 2003-05-16 08:41:17 EDT
I experienced no output from rpm -q after an upgrade to test-4.2 too, although
the silence went away after about 30 minutes. I assumed it was because the db
was still being rebuilt in the background or something, but I don't know for
sure. See Bug 90931.
Comment 3 Jeff Johnson 2006-01-06 11:27:41 EST
I suspect that the problem was fixed in patch2 to db-4.1.25 from sleepycat, as
there were excessive selects when blocked on some resource temporarily.

Otherwise, this bug is ancient. Reopen if you can reproduce with rpm-4.2.3 or later.
Comment 5 Bill Nottingham 2007-01-02 13:46:48 EST
Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
f you are currently still running Red Hat Linux 7.3 or 9, you are strongly
advised to upgrade to a current Fedora Core release or Red Hat Enterprise Linux
or comparable. Some information on which option may be right for you is
available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.