Bug 89737 - Error from libc.so.6 while installing Oracle9i
Summary: Error from libc.so.6 while installing Oracle9i
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-27 06:43 UTC by Ian Major
Modified: 2016-11-24 14:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-27 08:09:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Major 2003-04-27 06:43:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705; .NET CLR 1.1.4322)

Description of problem:
I'm getting the following running the Oracle9i installer on RedHat9.

It's a fresh install of RedHat (Server option), new install of Oracle (standard 
install).
I ran the RedHat network to update to all the latest updates.

So far I've tried IBM, Sun and Blackdown's JDK's 1.3.1 and 1.4.1.

Same error each time, see log file.

Version-Release number of selected component (if applicable):
2.3.2-27*

How reproducible:
Always

Steps to Reproduce:
1. Install RedHat Linux 9 as Server
2. Install JDK
3. Modify as per the Oracle Install guide
4. Run the Oracle Installer
    

Actual Results:  The install hangs at 0%

Expected Results:  Installer runs, being able to use the GLIBC2.0 libraries

Additional info:

See log files

Comment 1 Ian Major 2003-04-27 06:57:30 UTC
Adding this here since adding an attachment timed out 3 times...

java.lang.UnsatisfiedLinkError: /tmp/OraInstall2003-04-27_12-58-
25AM/libactionUnix22.so: /tmp/OraInstall2003-04-27_12-58-
25AM/libactionUnix22.so: symbol errno, version GLIBC_2.0 not defined in file 
libc.so.6 with link time reference
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1419)
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1314)
	at java.lang.Runtime.load0(Runtime.java:698)
	at java.lang.System.load(System.java:797)
	at ssOiGenClassux22.<clinit>(ssOiGenClassux22.java:25)
	at sscreateLinkux.createLink(sscreateLinkux.java:255)
	at sscreateLinkux.installAction(sscreateLinkux.java:83)
	at oracle.sysman.oii.oiis.OiisCompActions.doActionWithException
(OiisCompActions.java:1357)
	at oracle.sysman.oii.oiis.OiisCompActions.doActionImpl
(OiisCompActions.java:1157)
	at oracle.sysman.oii.oiis.OiisCompActions.doAction
(OiisCompActions.java:604)
	at CompActions.doActionP1createLink3(CompActions.java:310)
	at CompActions.stateChangeActions(CompActions.java:106)
	at oracle.sysman.oii.oiic.OiicInstallActionsPhase$OiilActionThr.run
(OiicInstallActionsPhase.java:604)
	at oracle.sysman.oii.oiic.OiicInstallActionsPhase.executeProductPhases
(OiicInstallActionsPhase.java:2199)
	at oracle.sysman.oii.oiic.OiicInstallActionsPhase.doInstalls
(OiicInstallActionsPhase.java:2052)
	at oracle.sysman.oii.oiic.OiicInstallActionsPhase$OiInstRun.run
(OiicInstallActionsPhase.java:2945)
	at java.lang.Thread.run(Thread.java:484)


Comment 2 Jakub Jelinek 2003-04-27 08:09:52 UTC
This is Oracle bug, which is not #include <errno.h> when using errno.
Please take it up with Oracle.
As a workaround, you can run the program with LD_ASSUME_KERNEL=2.4.1 in the 
environment.


Note You need to log in before you can comment on or make changes to this bug.