Bug 89745 - bash - readline - vi mode starts in input mode not command mode
Summary: bash - readline - vi mode starts in input mode not command mode
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-27 14:30 UTC by Peter Scott
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-07 16:30:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Scott 2003-04-27 14:30:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
When an old command is on the command line for the purpose of editing it, you
have to hit escape to put the editing into command mode before you can move to
the part you want to alter.  It wasn't so in any version of bash I have ever used.

It appears to be a bug rather than a configuration problem because copying the
bash binary from RH 7.3 (GNU bash, version 2.05a.0(1)-release
(i686-pc-linux-gnu)) cured it.

Version-Release number of selected component (if applicable):
bash-2.05b-5.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. hit arrow down
2. hit arrow up
3. hit w
    

Actual Results:  The w is inserted at the start of the old command.

Expected Results:  The cursor should move to the next word of the old command.

Additional info:

I can't believe no one else has reported this and hope it isn't in RH 9.0

Comment 1 Tim Waugh 2003-05-07 16:30:27 UTC
Upstream maintainer says this is not a bug, but intentional: see
/usr/share/doc/bash-*/NEWS.


Note You need to log in before you can comment on or make changes to this bug.