Bug 89747 - RFE: really a minimal installation
RFE: really a minimal installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
1
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Fulbright
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-27 13:01 EDT by acount closed by user
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-10 16:26:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2003-04-27 13:01:54 EDT
Description of problem:

There are too much packages at _minimal_ installation and it take a lot of space
490MB. I would like a _really mininal_ for firewall/routers.... and with the
possibility of doesn't install documentation(/usr/share/doc/) with the rpm
option  "--excludedocs"

-thanks-

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.-
2.-
3.-
    
Actual results:


Expected results:


Additional info:
Comment 1 Michael Fulbright 2003-04-28 16:26:33 EDT
With kickstart you can select '@Core' and save some space, but in general we do
not intend on reducing the size of the minimal interactive installation.  It is
a reasonable size considering the sizes and costs of disk drives over the past
few years.  The 'RULE' project is addressing running Red Hat Linux on smaller
footprint machines and may have some ideas to help you customize an installation.
Comment 2 acount closed by user 2003-04-29 15:03:41 EDT
well,  when I speak about a minimal installation is because it has minus
maintenance and it is more secure by default. And you avoid to make a personal
configuration and/or to apply a lot of paches.
 This is a very necessary feature  in a lots of environments. I needed this one
last year when I was implemented a 25 snort systems with rh linux. And I feel
that the next time will have to do the same operation.
It was only an idea for  to not waste the time.

-thank you-
Comment 3 Jonathan M. Slivko 2003-11-08 23:07:51 EST
What about taking the approach Debian did when creating their
distribution, install only what is necessary and leave everything else
upto the user to install later. This is generally the most secure way
to do things, I find. Maybe it's about time RedHat took the same approach.
Comment 4 Jeremy Katz 2003-11-08 23:37:40 EST
The problem with this approach is that you either end up 
a) installing X always which pisses people off or
b) have to use a text-mode program which is a loss in many respects
Comment 5 Jonathan M. Slivko 2003-11-09 09:26:00 EST
So let the user decide whether they want to install X or not? You
could have 2 options in the installer: Base Install - Text Mode or
Base Install - XWindows Mode.
Comment 6 Jeremy Katz 2003-11-10 16:26:47 EST
You then still have to reproduce all of the infrastructure that
currently exists for after installation.  This isn't something that is
currently interesting IMHO.
Comment 7 Jonathan M. Slivko 2003-11-10 16:31:26 EST
Why not let the community decide for themselves?
Comment 8 Vano Beridze 2004-02-26 03:46:37 EST
Hello

I'm a software developer and I'd like to have everything installed
under my control. I don't know how to use kickstart installation and I
would be very happy to do it with usual installation. I want to have
only those packages that are needed for
starting the system and rpm to install other packages. I really admire
the approach gentoo has. unfortunately gentoo is slower than redhat
for java development. sorry for being little bit offtopic.

I think it's really annoying to have installed by default packages
such as ypbind,yp-tools,sendmail and many more that are not needed for
me. Again it's not a problem of a space it's matter of having only
those packages that you need and with their respective manual if you
would like so.

If now minimal installation installs the distribution suited for small
firewall, routers then call it firewall/router distribution. And
please make a real minimal distribution. Linux is about choice is not it?

Note You need to log in before you can comment on or make changes to this bug.