Bug 8975 - Python caused problems
Summary: Python caused problems
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-30 05:59 UTC by jiang_fu
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-04-14 20:32:55 UTC


Attachments (Terms of Use)

Description jiang_fu 2000-01-30 05:59:42 UTC
This happend when I try to install RH6.1 from my hardisk.
After "Read Package Information..."
The system shows:
Exception Occured
Traceback(innermost last):
File "usr/bin/anaconda/real",line225,in ?
inf.run(todo,test=test)
File "/tmp/lib/python1.5/site-packages/text.py,line 1000,in run
rc=apply(step[1](1),step[2])
File "/mnt/redhat/comps/install/6.1/i386/misc/src/trees/hdimage/usr
/lib/python1.5/site-packages/textw/packages.py",line 10,in __call__
File "tmp/lib/python1.5/site-packages/harddrive.py",lie45,in readHeaders
isys.umount("/tmp/hdimage")
File "/tmp/lib/python1.5/site-packages/isys.py",line8 in umount
return _isys.umount(what)
SystemError:(16,'Device or resource busy')

I tried several times to configure RH6.1 but this problem still exist.
Since I successfully installed SuSe6.1 and BluePoint on the same machine,
I am sure this is not a compatability problem or configuration problem.
Fortunately I download before I decide to buy RH. Last week one of my
classmates persuaded my badly to buy his RH6.1 Deluxe at half price
although he bought three days ago. I think he meet the same problem of
this installation bug.

Comment 1 Nalin Dahyabhai 2000-02-10 16:58:59 UTC
Please try again with the updated boot disk and the installer updates disk
available from our web site at
http://www.redhat.com/support/errata/RHEA1999045-01.html
There were quite a few kinks to be worked out in the installer, and this may
well have been one of them.

A quick glance at the harddrive.py file in the install tree shows that it might
also have problems if you have files in RedHat/RPMS that aren't actually RPM
packages.  If you have a file named TRANS.TBL or any ls-lR or ls-lR.gz files in
there, I suggest you delete them.


Note You need to log in before you can comment on or make changes to this bug.