Bug 8975 - Python caused problems
Python caused problems
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 00:59 EST by jiang_fu
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-14 16:32:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jiang_fu 2000-01-30 00:59:42 EST
This happend when I try to install RH6.1 from my hardisk.
After "Read Package Information..."
The system shows:
Exception Occured
Traceback(innermost last):
File "usr/bin/anaconda/real",line225,in ?
inf.run(todo,test=test)
File "/tmp/lib/python1.5/site-packages/text.py,line 1000,in run
rc=apply(step[1](1),step[2])
File "/mnt/redhat/comps/install/6.1/i386/misc/src/trees/hdimage/usr
/lib/python1.5/site-packages/textw/packages.py",line 10,in __call__
File "tmp/lib/python1.5/site-packages/harddrive.py",lie45,in readHeaders
isys.umount("/tmp/hdimage")
File "/tmp/lib/python1.5/site-packages/isys.py",line8 in umount
return _isys.umount(what)
SystemError:(16,'Device or resource busy')

I tried several times to configure RH6.1 but this problem still exist.
Since I successfully installed SuSe6.1 and BluePoint on the same machine,
I am sure this is not a compatability problem or configuration problem.
Fortunately I download before I decide to buy RH. Last week one of my
classmates persuaded my badly to buy his RH6.1 Deluxe at half price
although he bought three days ago. I think he meet the same problem of
this installation bug.
Comment 1 Nalin Dahyabhai 2000-02-10 11:58:59 EST
Please try again with the updated boot disk and the installer updates disk
available from our web site at
http://www.redhat.com/support/errata/RHEA1999045-01.html
There were quite a few kinks to be worked out in the installer, and this may
well have been one of them.

A quick glance at the harddrive.py file in the install tree shows that it might
also have problems if you have files in RedHat/RPMS that aren't actually RPM
packages.  If you have a file named TRANS.TBL or any ls-lR or ls-lR.gz files in
there, I suggest you delete them.

Note You need to log in before you can comment on or make changes to this bug.