Bug 8977 - Baud rates work oddly in rp3-config
Baud rates work oddly in rp3-config
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 02:53 EST by janc
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 17:35:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description janc 2000-01-30 02:53:00 EST
If you change the baud rate setting on your modem after you've created
an account, the baud rate setting associated with that account does
not change.  Baud rates seem to be saved in three places - the
default entry in wvdial.conf, the individual account entries in wvdial.conf
and the ifcfg-ppp* files.  It appears that changing the modem baud
rate changes only the "Default" value in wvdial.conf which is not
inherited by anything because all the specific account entries
explicitly specify the baud rates that was the default when they were
created.

It took me many hours to figure out why outgoing ftp's were very
slow on my machine - I had created the account before I configured
the modem (which is natural enough since the account screen is shown
first), so although everything looked OK on the rp3-conf screens looked OK,
the wrong baud rate was being set by the pppd options.  The only way I
found to set this right was to manually edit the ifcfg-ppp and wvdial.conf
files.
Comment 1 Nalin Dahyabhai 2000-02-04 20:18:59 EST
This should be fixed in the Raw Hide version (currently at 1.0.7), which will
probably become an errata within a week or two.  Please upgrade to it and see
if it solves your problem.
Comment 2 Stephen John Smoogen 2003-01-24 17:35:49 EST
Bug 8977 has been closed because last input from user on possible fix was in
2000. If you experience this problem in Red Hat Linux 8.0 above, please open a
new ticket.

Note You need to log in before you can comment on or make changes to this bug.