Bug 89784 - Dell Inspiron 5000 install troubles
Dell Inspiron 5000 install troubles
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-04-28 07:14 EDT by Bas Mevissen
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-07-30 06:06:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bas Mevissen 2003-04-28 07:14:27 EDT
Description of problem:
In contrary to former Red Hat Linux version, I experienced some troubles during 
installation of RHL 9 on my notebook:

1) X display during install scrambled. My notebooks panel was not recognised 
(is 15" 1400x1050 display). Video Card was recognised properly (ATI Rage 
Mobility with 8MB RAM). Screen had only correct display in small strip (50-100 
pixel?) on the left side of the screen. The rest had a solid color, first blue, 
then gray. Color has a relation to what is displayed on the screen. I retried 
this 2 times with the same result.

2) Keyboard freeze during install. During install (in text mode because of 
1) ), a few times the keyboard froze. Even the caps lock LED didn't react. 
Closing and opening the lid (causing a standby-in-RAM) did unlock the keyboard. 
Noteable pressing shift-Fx to (try to) switch VC made the problem worse. I did 
retry this a few times, with varying results.

Note: I verified the installing media. Everything fine. I did a clean install 
on a computer with newly created partitions (fdisk-ed).

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Find Dell Inspiron 5000 (P-III, 600MHz, 512MB RAM, 30GB disk)
2. Put RHL 9 cdrom 1 in it and let it boot from it.
3. Just accept default everywhere -> problem 1)
4. Restart and now run "linux text".
5. Select all packages to install.
6. Press shift-Fx a few times
7. Note that pressing enter when a new cdrom is requested fails.
Actual results:
See problem description. Unable to install in graphics mode. Text mode could 
only be completed because of close-lid trick.

Expected results:
A problemless install like with RHL 7.x and 8.0.

Additional info:
No problem to test some stuff. Small dl's appreciated!
Comment 1 Michael Fulbright 2003-04-28 15:15:43 EDT
Could you try booting into the graphical installer by adding
'resolution=1400x1050' to your boot command line (assuming 1400x1050 is the LCD
native resolution).
Comment 2 Bas Mevissen 2003-04-28 18:21:47 EDT
Did add the resolution=1400x1050 and this was in the log:

* adding extraArg --resolution=1400x1050
* ddcprobe returned bogus values
ID:     None
Name:   None
HorizSync: None
VertSync:  None
Screen full gray without mouse pointer, while at first the mouse pointer was
visable in the small strip on the left. So we are further from home now :-)

I tried ddcprobe on the running system. It worked a few times tonight, but now
(a few hours later), not anymore??? Very strange. I tried it as root in runlevel
3 and 5...
Comment 3 Michael Fulbright 2003-05-13 12:34:27 EDT
I do not have this hardware to test with. Sounds like most X server related issues.
Comment 4 Bas Mevissen 2003-07-30 06:06:27 EDT
Don't have hardware anymore, so will not be able to try something anymore.

Note You need to log in before you can comment on or make changes to this bug.