Bug 89786 - installation on dual boot system raises RPMDB errors and results in incomplete installation
installation on dual boot system raises RPMDB errors and results in incomplet...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-28 08:55 EDT by Alexander Stohr
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 20:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Stohr 2003-04-28 08:55:58 EDT
Description of problem:
install RH 9.0 after RH 7.3 and you will end up in a 9.0 system
that solely provides the minimum software packages 
despite the installation process extracted all RPMs.
in particular, "mc" Midnight Commander is missing 
and any X11 window manager does expose major problems on launch.

the installation will show this error message on the console
before hitting the "reboot into final system" button:
  rpmdb: fatal region error detected; run recovery

Version-Release number of selected component (if applicable):
RH 9.0

How reproducible:
always

Steps to Reproduce:
1. install RH 7.3
2. install RH 9.0
3. on reboot screen switch consoles to see installer errors
4. reboot system
    
Actual results:
console error message:  rpmdb: fatal region error detected; run recovery
missing packages in rebooted system

Expected results:
there should not be any error messages on the installer console.

if there are such serious error in the rpmdb, then the installer
should take care for them and issue a serious error message about them.

the installed system should be complete.

Additional info:
there is a related bug that describes errors with e2/e3 labeling
that happened with same machine in same dual boot config,
maybe that problem is dependent in some way to the spotted results.

at least the root cause of the rpmdb error message should be 
identified, adequately handled and therefore resolved.
Comment 1 Alexander Stohr 2003-04-28 08:57:32 EDT
related bug is 89785
Comment 2 Jeremy Katz 2003-05-16 17:47:37 EDT
What are the contents of /root/install.log?
Comment 3 Alexander Stohr 2003-05-19 06:06:47 EDT
sorry cant provide that file any more - since the attempted install
was not really usable it got purged from the system and done a different way.
its some 4 weeks now since that bogus attempt.

i recommend that you try it once yourselves, 
we tried it twice here and found it reproduceable.
Comment 4 Jeremy Katz 2003-07-24 20:03:24 EDT
Unable to reproduce here.

Note You need to log in before you can comment on or make changes to this bug.