Bug 89819 - evolution can't start, oaf problems
Summary: evolution can't start, oaf problems
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: oaf   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-28 19:53 UTC by Marius Andreiana
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 04:08:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marius Andreiana 2003-04-28 19:53:35 UTC
When starting evolution once ( after a clean shutdown ), it complained about
Missing configuration database. 

During troubleshooting, I've also run 'bonobo-moniker-xmldb' which hanged,
nothing displayed. Please make it work around whatever the problem was, or give
more explanations, not hang.

oaf-slay run as a regular user gives ( as root there's no error )
panic: end_shift at /usr/bin/oaf-slay line 138.

Finally the evolution problem was solved was solved by removing /tmp/orbit-$user
and killing all oaf processes by hand. wombat gave no error when started separately.

Now bonobo-moniker-xmldb runs ok. So the only reproductible bug is oaf-slay.

Comment 1 Havoc Pennington 2003-10-09 04:08:52 UTC
With evolution 2.4 should have different bugs. I still get some bonobo/orbit
goofiness sometimes, but not reproduceably enough to track down.


Note You need to log in before you can comment on or make changes to this bug.