Bug 89829 - octave-2.1.34-6.src.rpm fails to build on AS2.1-QU2-beta
Summary: octave-2.1.34-6.src.rpm fails to build on AS2.1-QU2-beta
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: octave   
(Show other bugs)
Version: 2.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-28 20:18 UTC by Glen A. Foster
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-29 20:21:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "rpmbuild -ba" (94.94 KB, text/plain)
2003-04-28 20:19 UTC, Glen A. Foster
no flags Details

Description Glen A. Foster 2003-04-28 20:18:40 UTC
Description of Problem: SSIA.  Performing a re-build of octave from the SRPM 
fails on an everything install of AS2.1-QU2-beta.  Build log is attached.

Version-Release number of selected component (if applicable):
# ls -l octave-2.1.34-6.src.rpm
-rw-r--r--    1 root     root      3828631 Nov 26  2001 octave-2.1.34-6.src.rpm
# md5sum octave-2.1.34-6.src.rpm
8acf36907f1174e6673a9705435c0a99  octave-2.1.34-6.src.rpm

How Reproducible: always (100%)

Steps to Reproduce:
1. AS2.1-QU2-beta "everything" install
2. rpm -Uvh {distdir}/SRPMS/octave-2.1.34-6.src.rpm
3. rpmbuild -ba /usr/src/redhat/SPECS/octave.spec

Actual Results:
Out of "rpmbuild -ba" is attached

Expected Results:
Successful build

Comment 1 Glen A. Foster 2003-04-28 20:19:02 UTC
Created attachment 91356 [details]
Output of "rpmbuild -ba"

Comment 2 Lon Hohberger 2003-05-28 14:14:44 UTC
Reproduced this.

Comment 3 Lon Hohberger 2003-05-29 20:21:55 UTC
Actually, this is caused by a bug in gcc/g++ iostream libraries, and will be
fixed in the final release of QU2.

Output from a program which was redirected or piped to the standard input of
another program was getting quashed.  This caused the documentation-generating
helper "gethelp.cc" in the scripts directory in the source tree to fail. 
Texinfo was complaining about 'invalid doc format' - which is true - because the
file it was trying to read was empty.



Note You need to log in before you can comment on or make changes to this bug.