Bug 89832 - killall leaves processes unkilled and are inherited by init
Summary: killall leaves processes unkilled and are inherited by init
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: psmisc (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-28 20:26 UTC by Carmen Piper
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 08:40:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
code for script and C programs used in reproducing bug (1.07 KB, text/plain)
2003-04-28 20:29 UTC, Carmen Piper
no flags Details

Description Carmen Piper 2003-04-28 20:26:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When invoked using a process name, killall sometimes leaves a straggler process.
 A kill is never issued on behalf of this process and the process is inherited
by init.



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Large number of processes are created with the same name
2. A killall specifying the process name is issued
3. Since it is not reproduceable every time, I do this in a loop.  
A script is attached that reproduces this behavior

Actual Results:  
One of the processes is left unkilled.  From tracing I can see that a kill is
not issued on its behalf.  The process is inherited by init.



Expected Results:  All processes matching the specified name should be killed.

Additional info:

carmen@cuda killall]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 10
cpu MHz         : 1000.132
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr sse
bogomips        : 1985.67

Comment 1 Carmen Piper 2003-04-28 20:29:02 UTC
Created attachment 91358 [details]
code for script and C programs used in reproducing bug

Comment 2 Karel Zak 2004-12-14 12:21:18 UTC
Can you reproduce it on new distribution?

I tried your test (18 loops) and I cannot confirm this bug. 
I have FC-3.

Comment 3 Karel Zak 2005-04-12 08:40:05 UTC
No response ... closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.