This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 8984 - lilo dos entry misses table = line
lilo dos entry misses table = line
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 10:56 EST by Hans de Goede
Modified: 2015-01-07 18:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 11:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-01-30 10:56:19 EST
After doing an upgrade on my laptop my lilo.conf looked like this:
boot=/dev/hda
map=/boot/map
install=/boot/boot/b
linear
default=linux

image=/boot/vmlinuz-2.2.14-1.1.0
	label=linux
	read-only
	root=/dev/hda1

other=/dev/hda3
	label=dos

The last entry should ofcourse be:

other=/dev/hda3
	table=/dev/hda
	label=dos
Comment 1 Jay Turner 2000-02-04 11:45:59 EST
The "table=" line is only appropriate for some DOS installations.  There are
others that the "table=" line would cause the lilo installation to fail.  We err
on the side of lilo running to completion in this case.
Comment 2 Hans de Goede 2000-02-04 18:47:59 EST
Afaik, all previous versions of RH did add the table = line, besides that afaik
most systems won't boot into dos without this line.

For a new user, not having his multiboot working is going to be a big pain, and
a very negative linux experience.

For an experienced user this is an annoyance too, since he expects it to work
(it has always worked with previous versions)

So looking from the element of the least surprise, and in its a .x release, so
letts not change any majro principle. I would like you to rethink this.

Note You need to log in before you can comment on or make changes to this bug.