Bug 89856 - stty erase yields errors on dumb terminal
stty erase yields errors on dumb terminal
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: zsh (Show other bugs)
GinGin64
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-28 18:29 EDT by Ben Liblit
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version: 4.0.6-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-19 16:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Liblit 2003-04-28 18:29:12 EDT
Description of problem:

When a zsh shell is started on a dumb terminal, error diagnostics appear stating
that stty is missing an argument to "erase".

Version-Release number of selected component (if applicable):

zsh-4.0.6-5

How reproducible:

Consistently.

Steps to Reproduce:
1. Run "TERM=dumb zsh".  That is, launch zsh with $TERM set to "dumb".
    
Actual results:

Diagnostic messages appear:

   stty: missing argument to `erase'
   Try `stty --help' for more information.

Expected results:

Silent startup with no error messages.

Additional info:

The problem is on the last line of "/etc/zshrc", which reads:

   stty erase `tput kbs`

On a dumb terminal, the tput command exits with an error and produces no output,
effectively reducing this to "stty erase" with no second argument.

This can be fixed quite easily by putting double quotes around the backtick clause:

   stty erase "`tput kbs`"
Comment 1 Jens Petersen 2003-04-30 21:26:17 EDT
Thank you for the report. I'll fix this in the next build into rawhide.

The fixed package should be zsh-4.0.6-7.

Note You need to log in before you can comment on or make changes to this bug.