Bug 8986 - export to IP address fails when DNS PTR record exists
export to IP address fails when DNS PTR record exists
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 11:44 EST by cmackin
Modified: 2007-04-18 12:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-04 13:58:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cmackin 2000-01-30 11:44:17 EST
If the /etc/exports file exports a directory to an IP address, and a PTR
record exists for that IP in DNS, mounting that export from the specified
machine fails.

Changing the IP address to the DNS name in the exports file and restarting
the NFS server causes the mount to succeed.
Comment 1 Cristian Gafton 2000-08-08 22:34:06 EDT
assigned to johnsonm
Comment 2 Stephen John Smoogen 2003-01-24 11:19:34 EST
Is this problem still existant in Red Hat Linux 7.3 or 8.0? I could not
duplicate this at home with 8.0 but my test environment is not extensive.
Comment 3 cmackin 2003-02-03 17:36:00 EST
Get serious! I reported this bug three years ago, as a good faith gesture. I
don't use RH7.0 anymore -- I don't even use NFS anymore.

Either the bug's been fixed, or it is still there. If you're conscientious,
you'll check - which means finding out why it failed in the first place, and
when/how it got fixed. Putting the onus on me, after three years, to do your QA
for you -- "ooh, I need more information from the customer, or I'm helpless" --
is a bit much. Assuming that everything's OK just because you can't reproduce on
the current release is sloppy.

While I recognize that the person now asking for more info probably isn't the
one who has ignored the bug report these long years, I also recognize a cop-out
when I see one. 'Scuse the flame, but thinking about the 'net three years ago
made me nostalgic.
Comment 4 Steve Dickson 2003-02-04 13:58:45 EST
Unable to reproduce in current release

Note You need to log in before you can comment on or make changes to this bug.