Bug 89873 - RPM DB_Verify Bad
RPM DB_Verify Bad
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-29 01:17 EDT by Kevin Hedges
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-29 11:40:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Hedges 2003-04-29 01:17:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
Fresh installtion of Red Hat 9.0 reports a corrupted Package database.

Version-Release number of selected component (if applicable):
RPM-4.2 - Release vesion with RH 9.0

How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat 9.0 on fresh machine (Not an upgrade)
2.run rpm -qa |sort |less 
3.check the /var/lib/rpm directory for __db.* files and delete if found.
4.run db_verify Packages 
5.Again delete the  __db.* files (__db.001,--db.002,--db.003)
6 Run RPM --rebuilddb

I have removed all locked files and rebuilt the machine at least 6 times.   

Actual Results:  region error detected Run recovery
old or incorrect DB version
DB_verify Bad

Database fails to rebuild without error.
Up2date fails to update system- Downloads files but wont install.

Expected Results:  Rpm database to work as is, out of the box and up2date to 
maint system file levels and security updates

Additional info:

ISO images have been downloaded 3 times from Red Hat and the result is the 
same. Md5sum has been run against the ISO images and check sums verified. The 
disk created from the image have been check prior to installation. 
The install has been done on more than one machine.
Comment 1 Jeff Johnson 2003-04-29 11:40:59 EDT
Yes, db_verify (from db4-4.0.14) will fail because
rpm uses db-4.1.25 which is backward but, alas, not
forward compatible.

Use /usr/lib/rpm/rpmdb_verify instead.

BTW, you probably also want rpm-4.2-1 packages, currently at
    ftp://ftp.rpm.org/pub/rpm/test-4.2
There's a fix for possible stale locks there.

Please reopen this bug if ther are additional problems.

Note You need to log in before you can comment on or make changes to this bug.