Bug 89879 - X configuration incorrect for a Geforce 4 connected to a DVI monitor
X configuration incorrect for a Geforce 4 connected to a DVI monitor
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-29 06:10 EDT by Liam Bedford
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 17:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liam Bedford 2003-04-29 06:10:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b)
Gecko/20030424 Chimera/0.7+

Description of problem:
When running the graphical installer, X runs, but doesn't display. The nv driver
doesn't detect the output port correctly, and tries to display to the analog VGA
port.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from CD 1
2. choose the ordinary install (graphical)
3. anaconda detects a gf4, and starts X
    

Actual Results:  blank screen on monitor

Expected Results:  display of graphical installer

Additional info:

There are a couple of workarounds:
1) plug monitor into the analog port (only works if you have an analog VGA
monitor though)
2) use fbdev. This displays okay on whatever the BIOS booted on.

There are also a couple of fixes until the nv driver in XF86 is fixed to
autodetect output port correctly:
1) use the nvidia binary driver
2) add two lines to the Device "nv" section. I don't have them right here, but
IIRC, they are Option "FlatPanel" "true", and Option "CrtcNumber" "0" or "1" (I
found out which one works on mine by guess work :(
Comment 1 Michael Fulbright 2003-04-29 12:11:37 EDT
Adding the extra options would have to be handled by redhat-config-xfree86 and rhpl.

Also it would seem X needs to just do the right thing here w/o intervention.
Comment 2 Mike A. Harris 2004-09-29 17:42:48 EDT
DVI detection was not implemented completely in the XFree86 4.3.0
'nv' driver release, and was only experimental.

The current release of X11 we are shipping in Fedora Core has
enhanced support for DVI on Nvidia hardware.  We encourage you
to upgrade to the latest version of Fedora Core, which can be
obtained at (http://fedora.redhat.com).

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.